cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wido den Hollander <w...@widodh.nl>
Subject [DISCUSS] API changes / compatibility between 4.1 and 4.2
Date Tue, 23 Jul 2013 16:00:37 GMT
Hi,

Yesterday I encountered this bug: 
https://issues.apache.org/jira/browse/CLOUDSTACK-3714

A short summary: A 4.2 agent can't communicate with a 4.2 management 
server and vise versa.

What this means is that during an upgrade you can't upgrade the Agents 
one by one, since a upgraded Agent won't be able to participate in the 
cluster.

This is a big breaker for me, since going from 4.1 to 4.2 and having to 
shut down your management server and all your Agents at once seems like 
a major upgrade to me.

I also encountered the problems with the new SystemVMs today while 
upgrading my management server to 4.2 and it seems to me that this 
upgrade won't be an easy one for a lot of users.

So I'd like to start a discussing about this, since I'm almost thinking 
that 4.2 should become 5.0 because of the major changes.

These major changes are good and they bring a lot of functionality to 
CloudStack, but sometimes it seems like stuff is coming in so fast that 
it's almost impossible to keep up with.

How do other people think about this API change between 4.1 and 4.2?

Do you also think that 4.2 should actually be called 5.0?

Wido

Mime
View raw message