cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ram Ganesh <Ram.Gan...@citrix.com>
Subject RE: Using VMware from CloudStack
Date Thu, 11 Jul 2013 05:46:28 GMT
Association of DC to a Zone was introduced as part of [1]. With this change VCenter details
at the "Add Cluster" page should be optional to take care of legacy zones(zones created prior
to [1] support). This could be a bug in UI

[1] https://cwiki.apache.org/confluence/display/CLOUDSTACK/Mapping+model+for+CloudStack+zone+and+Vmware+datacenter


> -----Original Message-----
> From: Mike Tutkowski [mailto:mike.tutkowski@solidfire.com]
> Sent: 11 July 2013 01:57
> To: dev@cloudstack.apache.org; Ahmad Emneina
> Subject: Re: Using VMware from CloudStack
> 
> Hi Ahmad,
> 
> Yeah, it seems to ask for vCenter credentials both when adding the VMware
> Datacenter to the Zone and when creating a CS Cluster based on a VMware
> Cluster.
> 
> Interesting
> 
> 
> On Wed, Jul 10, 2013 at 2:02 PM, Ahmad Emneina <aemneina@gmail.com>
> wrote:
> 
> > one typically adds a cluster during zone creation or adds the cluster
> > as a unit (which maps to the vmware dc/cluster). I believe at the
> > cluster addition phase, is where you should be prompted for
> > credentials. Give that a try, see if you get any miles out of that.
> >
> >
> > On Wed, Jul 10, 2013 at 12:35 PM, Mike Tutkowski <
> > mike.tutkowski@solidfire.com> wrote:
> >
> > > Hi,
> > >
> > > I've been primarily working on the 4.2 branch as of late and was
> > > setting
> > up
> > > a VMware cluster for the first time in a while.
> > >
> > > I noticed from an error message that before I can set up a cluster
> > > based
> > on
> > > VMware that I must add the VMware Datacenter to the Zone. I went
> > > ahead
> > and
> > > did this.
> > >
> > > I then came back to the Add Cluster dialog and am wondering why at
> > > this point we ask for the vCenter host, username, password, and
> > > datacenter. It would seem I already filled in this info when I
> > > associated the VMware Datacenter to the Zone. Am I missing something
> here?
> > >
> > > Thanks for filling me in on this!
> > >
> > > --
> > > *Mike Tutkowski*
> > > *Senior CloudStack Developer, SolidFire Inc.*
> > > e: mike.tutkowski@solidfire.com
> > > o: 303.746.7302
> > > Advancing the way the world uses the
> > > cloud<http://solidfire.com/solution/overview/?video=play>
> > > *(tm)*
> > >
> >
> 
> 
> 
> --
> *Mike Tutkowski*
> *Senior CloudStack Developer, SolidFire Inc.*
> e: mike.tutkowski@solidfire.com
> o: 303.746.7302
> Advancing the way the world uses the
> cloud<http://solidfire.com/solution/overview/?video=play>
> *(tm)*

Mime
View raw message