cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Toshiaki Hatano" <toshiaki.hat...@verio.net>
Subject Re: Review Request 13004: Bug:advance zone, create public Network with vlan id specified, but the portgroup is cloud.public.untagged.0.1-vSwitch0 not cloud.public.[vlanid].0.1-vSwitch0
Date Wed, 31 Jul 2013 01:17:20 GMT


> On July 30, 2013, 11:13 p.m., edison su wrote:
> > I looked at latest 4.2 code, toURI() only contains one line code:  return new URI(scheme
+ "://" + value.toString());, thus can't apply your patch. Could you tell me which branch
are you using? The master?
> 
> Jijun wrote:
>     hi edison,
>     yes,it is in the master,not the branch 4.2.
> 
> edison su wrote:
>     Do you who made the change on master branch? 4.2 branch doesn't have this issue.

It suppose duplicate of patch https://reviews.apache.org/r/12849/ and https://reviews.apache.org/r/12985/.
If issue CLOUDSTACK-3883 is solved, CLOUDSTACK-3682 should be solved too.


- Toshiaki


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/13004/#review24296
-----------------------------------------------------------


On July 30, 2013, 12:58 a.m., Jijun wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/13004/
> -----------------------------------------------------------
> 
> (Updated July 30, 2013, 12:58 a.m.)
> 
> 
> Review request for cloudstack, daan Hoogland, edison su, and Wei Zhou.
> 
> 
> Bugs: https://issues.apache.org/jira/browse/CLOUDSTACK-3883
> 
> 
> Repository: cloudstack-git
> 
> 
> Description
> -------
> 
>  In lastest CS 4.2 code, I  create advance zone  with hypervisor vmware esxi,
> create public Network with vlan id 509 specified and  label vSwitch0, when cs create
systemvm(cpvm,ssvm),
> a new portgroup with  name  cloud.public.untagged.0.1-vSwitch0 was created, not a portgroup
cloud.public.509.0.1-vSwitch0 as expected. 
> in database table nics, the field broadcast_uri for new systemvm  is vlan:509  , and
should be vlan://509
> debug the code and found it is a syntax error in Networks.java for new instance java.net.URI.
> 
> 
> Diffs
> -----
> 
>   api/src/com/cloud/network/Networks.java c76c3d4 
> 
> Diff: https://reviews.apache.org/r/13004/diff/
> 
> 
> Testing
> -------
> 
> recreate the system vm or create a new advance zone , public network with vlan
> 
> 
> Thanks,
> 
> Jijun
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message