cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Venkata Siva Vijayendra Bhamidipati" <vijayendra.bhamidip...@citrix.com>
Subject Re: Review Request 12612: Fix NPE when attaching vmware-tools iso to guest VM on ESX
Date Wed, 17 Jul 2013 00:30:24 GMT


> On July 17, 2013, 12:24 a.m., Sheng Yang wrote:
> > plugins/hypervisors/vmware/src/com/cloud/storage/resource/VmwareStorageProcessor.java,
line 875
> > <https://reviews.apache.org/r/12612/diff/1/?file=322287#file322287line875>
> >
> >     need proper indent

Hmm, thanks for catching that. I cleaned some code in vim, must've caused the different indentation.
Passed git diff --check though. Will upload a new diff. 


> On July 17, 2013, 12:24 a.m., Sheng Yang wrote:
> > server/src/com/cloud/template/TemplateManagerImpl.java, line 999
> > <https://reviews.apache.org/r/12612/diff/1/?file=322288#file322288line999>
> >
> >     How can this happen?? Add Min Chen in reviewer.

This is because vmware tools or xenserver tools ISOs aren't actual ISOs. They're internally
provisioned by vmware/xenserver, so the URL will be null. Since it isn't really resident anywhere,
the image store will also be absent for it, i.e., null.


- Venkata Siva Vijayendra


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/12612/#review23217
-----------------------------------------------------------


On July 17, 2013, 12:18 a.m., Venkata Siva Vijayendra Bhamidipati wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/12612/
> -----------------------------------------------------------
> 
> (Updated July 17, 2013, 12:18 a.m.)
> 
> 
> Review request for cloudstack, Chip Childers, edison su, Kelven Yang, Sateesh Chodapuneedi,
and Sheng Yang.
> 
> 
> Bugs: CLOUDSTACK-3554
> 
> 
> Repository: cloudstack-git
> 
> 
> Description
> -------
> 
> Fixing NPE that occurs when attaching vmware-tools.iso to a guest VM on ESX.
> 
> 
> Diffs
> -----
> 
>   plugins/hypervisors/vmware/src/com/cloud/storage/resource/VmwareStorageProcessor.java
4113803 
>   server/src/com/cloud/template/TemplateManagerImpl.java c7cc818 
> 
> Diff: https://reviews.apache.org/r/12612/diff/
> 
> 
> Testing
> -------
> 
> With the fix in place, vmware-tools.iso attach to a vmware guest VM works as expected.
> 
> 
> Thanks,
> 
> Venkata Siva Vijayendra Bhamidipati
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message