cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rajesh Battala" <rajesh.batt...@citrix.com>
Subject Re: Review Request 12227: NPE while deploying any instances in kvm/vmware using ZWPS due to capacityIops
Date Thu, 11 Jul 2013 07:08:57 GMT


> On July 10, 2013, 9:57 p.m., edison su wrote:
> > Ship It!

Thanks Edison for the review and pushing the patch


- Rajesh


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/12227/#review22981
-----------------------------------------------------------


On July 4, 2013, 12:32 p.m., Rajesh Battala wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/12227/
> -----------------------------------------------------------
> 
> (Updated July 4, 2013, 12:32 p.m.)
> 
> 
> Review request for cloudstack, edison su, Ram Ganesh, and Sateesh Chodapuneedi.
> 
> 
> Bugs: 3301
> 
> 
> Repository: cloudstack-git
> 
> 
> Description
> -------
> 
> Issue: 
> When VM is getting deployed in ZWPS(kvm, vmware), NPE is occuring.
> 
> Fixed:
> SolidFire storage had introduced iops, its setting capacityIops on the pool level. Only
solidfire is setting and getting it which is causing NPE when checking this value for other
type PS.
> This fixed will resolve the issue for any storage provider which don't set capacityIops.
> 
> 
> Diffs
> -----
> 
>   server/src/com/cloud/storage/StorageManagerImpl.java bb21afb 
> 
> Diff: https://reviews.apache.org/r/12227/diff/
> 
> 
> Testing
> -------
> 
> 1. Adding ZWPS, and deployed the VM in KVM. Vm got successfully deployed.
> 2. Adding CWPS and deployed the VM in KVM. VM got deployed successfully.
> 
> 
> Thanks,
> 
> Rajesh Battala
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message