cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rohit Yadav <bhais...@apache.org>
Subject Re: CloudMonkey on PyPi
Date Tue, 04 Jun 2013 18:39:21 GMT
On Wed, Jun 5, 2013 at 12:05 AM, Chip Childers <chip.childers@sungard.com>wrote:

> The problem I'm seeing is that -SNAPSHOT is a newer version than -0, so
> 4.1.0-0 (the one I published from the release) isn't being downloaded.
> Instead 4.1.0-SNAPSHOT-3 is the one that's pulled.  Perhaps I'm just not
> configuring things right?  Knowing your schedule, if you don't mind
> taking a look and letting me know if perhaps I've done something wrong,
> that would be helpful.
>

Yes, that's the expected behavior. To download the release version 4.1.0-0,
one should do: pip install cloudmonkey==4.1.0-0 (or suitable version now
and in future).

In my view, one should get the latest and greatest (almost stable)
cloudmonkey and choose specific versions using == while installing.

If you want to enforce that, please go ahead the delete it. We can in that
case ask users to get the latest from the git repo.

Cheers.


>
> -chip
>
> On Tue, Jun 04, 2013 at 11:58:45PM +0530, Rohit Yadav wrote:
> > Hi Chip! I'm fine either ways. We don't really need to remove anything
> and
> > if you want you can remove the snapshot and put the said release in
> action.
> > My dayjob is very engaging so I'm finding less time hacking CloudStack,
> so
> > please go ahead with your judgement. I/we already welcome people who want
> > to help us maintain/publish cloudmonkey (any other components :) and the
> > release channel on pypi.
> >
> > I think as discussed in plethora of exchanges earlier, we'll release the
> > version release and snapshots. People who want the version release can
> do:
> > pip install cloudmonkey==<version>; most people who may want the latest
> and
> > the greatest can simply get the latest snapshot or release using pip
> > install cloudmonkey.
> >
> > Cheers.
> >
> > On Tue, Jun 4, 2013 at 2:08 AM, Chip Childers <chip.childers@sungard.com
> >wrote:
> >
> > > Hey Rohit,
> > >
> > > Do you think that we should remove the 4.1.0-SNAPSHOT artifacts from
> > > PyPi?  It's actually a higher version than 4.1.0-0 I think.
> > >
> > > -chip
> > >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message