cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jessica Tomechak <jessica.tomec...@gmail.com>
Subject Re: Upgrade failure. 2.2.14 to 4.1.0
Date Thu, 27 Jun 2013 05:52:42 GMT
Glen,
Thanks for sharing your experience. I'm sorry it has been frustrating.

When you encounter documentation errors, please do feel free to file this
as a bug. In this case, I have added your comments to a very similar bug
that was filed recently, as I have a feeling all the upgrade instruction
errors could be fixed at one time.

https://issues.apache.org/jira/browse/CLOUDSTACK-3138

Jessica T.



On Mon, Jun 17, 2013 at 12:42 AM, Wei ZHOU <ustcweizhou@gmail.com> wrote:

> The fix for Bug CLOUDSTACK-3005 may help you.
>
> -Wei
>
>
> 2013/6/16 Glen Baars <glen@onsitecomputers.com.au>
>
> > Hello Cloudstack dev,
> >
> > Just wanted to share my experiences on upgrading 2.2.14 to 4.1.0 with 6
> > Xenserver 5.6SP2 hosts.
> >
> > The documentation doesn't work, so many errors. I ended up restoring
> after
> > 25 hours back to 2.2.14.
> >
> > I am willing to edit the docs when I get the upgrade to work.
> >
> > I would suggest the following changes:
> >
> > 1.
> > Automatically take a mysqldump prior to the database upgrade.
> > If it fails, revert to the dump and log.
> >
> > This would be faster to diag / fix and leave the db in a usable state. I
> > know you should take a db backup first anyway, but this would be cleaner.
> >
> > 2.
> > The vhd-util download isn't on the upgrade guides.
> >
> > 3.
> > The upgrade guide for 4.1.0 incorrectly list the repos in the examples
> and
> > 4.0
> >
> > 4.
> > The upgrade guide gets cloud and Cloudstack folders wrong all the time
> >
> > 5.
> > I had an issue with a SR-BACKEND failure that ended up being a corrupt
> > vhd. This was throwing all kinds of errors with the solution. I know this
> > is a Xenserver issue, just might help others with SR-BACKEND failures.
> >
> > 6.
> > 4.0.2 Ubuntu repo install is missing the cloud-setup-encryption binaries.
> >
> > 7.
> > Can't upgrade from 2.2.14 to 4.0.2 due to a know bug that is listed as
> > solved due to 4.1.0 being released. This doesn't help when you can't get
> > 4.1.0 to work. ( bug is for the database conversion missing 4.02 schema
> > files ). If the upgrades don't work, can we put that on the upgrade
> guide /
> > release notes?
> >
> > This brings me to the issue that I am having.
> >
> > After the upgrade, I can't deploy any VDI's into the SR's. The secondary
> > storage is not getting mounted on the xenservers.
> >
> > The errors creating the secondary storage VM is below.
> >
> > http://pastebin.com/H4jZutuP
> >
> > Any ideas? I put the vhd-util in the correct location and set the
> > permissions.
> >
> > Just to confirm my upgrade steps
> >
> > 1. Upgrade my single Ubuntu 12.04LTS management server from 2.2.14 to
> > 4.1.0 2. rolling pool upgrade to Xenserver 5.6SP2 to 6.1 3. run the
> script
> > to reboot all virtual routers and system vm's
> >
> > I got to step three and no routers came back up :( due the to secondary
> > storage / SR issues.
> >
> > I have been looking for a way to contribute, maybe I can do Xenserver
> > upgrade testing. I am setting up a test lab for this issue currently.
> >
> > Regards,
> >
> > Glen Baars
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message