cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nguyen Anh Tu <ng.t...@gmail.com>
Subject Re: Unable to register templates and ISOs
Date Sat, 29 Jun 2013 09:26:01 GMT
I checked SSVM. Everything fine. DNS checking's ok and SSVM can connect to
MS port 8250. But it still can't register template. Log on MS said:

2013-06-29 15:38:35,133 DEBUG [storage.download.DownloadListener]
(Timer-5:null) Scheduling timeout at 30000 ms, TEMPLATE: 201 at host 0
2013-06-29 15:38:35,134 DEBUG [storage.download.DownloadListener]
(Timer-5:null) NOT_DOWNLOADED first timeout: checking again , TEMPLATE: 201
at host 0

2013-06-29 15:39:05,134 DEBUG [storage.download.DownloadListener]
(Timer-5:null) timeout: transitioning to download error state,
currstate=NOT_DOWNLOADED, TEMPLATE: 201 at host 0
2013-06-29 15:39:05,290 WARN  [storage.download.DownloadListener]
(Timer-5:null) Entering download error state: timeout waiting for response
from storage host, TEMPLATE: 201 at host 0



2013/6/29 Harikrishna Patnala <harikrishna.patnala@citrix.com>

> Can you try troubleshooting the SSVM by following this link
>
> https://cwiki.apache.org/CLOUDSTACK/ssvm-templates-secondary-storage-troubleshooting.html
> Probably agent is not running in the SSVM due to which no entry is created
> in the host table.
> please try building systemvm and recreate ssvm
>
> -Harikrishna
>
> On 29-Jun-2013, at 9:37 AM, Nguyen Anh Tu <ng.tuna@gmail.com<mailto:
> ng.tuna@gmail.com>>
>  wrote:
>
> Hi,
>
> I got the same issue. Log say "there is no secondary storage..." and I see
> no record for ssvm in host table in DB.
>
> I cc your question to dev maillist. Anyone can help?
>
> Sent from my GT-N7000
> On 29 Jun 2013 03:30, "Tim Schultheiss" <tschultheiss@dynamicquest.com
> <mailto:tschultheiss@dynamicquest.com>>
> wrote:
>
> Hi all,
>
> I have a CS 4.1 zone with XenServer 6.1 hosts. They were configured
> locally,
> disconnected and sent to a remote site, and then reconnected. After
> reconnecting, I cannot register anything to the secondary storage in this
> zone. I checked the logs and saw that it said that my two secondary storage
> shares have no storage hosts. I have restarted the SSVM, deleted both it
> and
> the Console Proxy, and verified that they were remade.
> I can create instances from any templates already imported. The status of
> any template or ISO created is blank, and if I attempt to copy one over
> from
> another zone, it fails as well.
>
> Can anyone offer any insight?
>
> Here's what the log says:
> 2013-06-28 14:21:45,987 DEBUG [cloud.api.ApiServlet]
> (catalina-exec-23:null)
> ===START===  74.122.165.4 -- GET
>
>
> command=registerIso&response=json&sessionkey=H4EadP%2Bc8GKR0Ym224FWLav13Tw%3
>
>
> D&name=CentOS+6.4+Minimal&displayText=CentOS+6.4+Minimal&url=http%3A%2F%2Fmi
> rrors.vpsnoc.com<http://rrors.vpsnoc.com>
> %2FCentOS%2F6%2Fisos%2Fx86_642FCentOS-6.4-x86_64-minimal.iso
>
>
> &zoneid=5f86ad9d-d8bc-4832-8fcb-838586f2ba5c&isextractable=false&bootable=tr
>
>
> ue&osTypeId=63d22a42-d9a9-11e2-a93bb6bd483074cc&ispublic=false&isfeatured=fa
> lse&_=1372443705867
> 2013-06-28 14:21:46,225 WARN  [storage.download.DownloadMonitorImpl]
> (catalina-exec-23:null) There is no secondary storage VM for secondary
> storage host nfs://10.147.36.75/export/secondary
> 2013-06-28 14:21:46,325 DEBUG [cloud.api.ApiServlet]
> (catalina-exec-23:null)
> ===END===  74.122.165.4 -- GET
>
>
> command=registerIso&response=json&sessionkey=H4EadP%2Bc8GKR0Ym224FWLav13Tw%3
>
>
> D&name=CentOS+6.4+Minimal&displayText=CentOS+6.4+Minimal&url=http%3A%2F%2Fmi
> rrors.vpsnoc.com
> %2FCentOS%2F6%2Fisos%2Fx86_642FCentOS-6.4-x86_64-minimal.iso
>
>
> &zoneid=5f86ad9d-d8bc-4832-8fcb-838586f2ba5c&isextractable=false&bootable=tr
>
>
> ue&osTypeId=63d22a42-d9a9-11e2-a93bb6bd483074cc&ispublic=false&isfeatured=fa
> lse&_=1372443705867
> 2013-06-28 14:22:00,453 DEBUG
> [storage.secondary.SecondaryStorageManagerImpl] (secstorage-1:null) Zone 10
> is ready to launch secondary storage VM
> 2013-06-28 14:22:01,218 DEBUG [cloud.consoleproxy.ConsoleProxyManagerImpl]
> (consoleproxy-1:null) Zone 10 is ready to launch console proxy
> 2013-06-28 14:22:03,252 DEBUG [cloud.server.StatsCollector]
> (StatsCollector-2:null) VmStatsCollector is running...
> 2013-06-28 14:22:03,295 DEBUG [agent.manager.ClusteredAgentAttache]
> (StatsCollector-2:null) Seq 26-927141969: Forwarding null to
> 147455086999471
> 2013-06-28 14:22:04,256 DEBUG [agent.transport.Request]
> (StatsCollector-2:null) Seq 26-927141969: Received:  { Ans: , MgmtId:
> 227165843378938, via: 26, Ver: v1, Flags: 10, {GetVmStatsAnswer } }
> 2013-06-28 14:22:04,282 DEBUG [agent.manager.ClusteredAgentAttache]
> (StatsCollector-2:null) Seq 27-1832978880: Forwarding null to
> 147455086999471
> 2013-06-28 14:22:05,365 DEBUG [agent.transport.Request]
> (StatsCollector-2:null) Seq 27-1832978880: Received:  { Ans: , MgmtId:
> 227165843378938, via: 27, Ver: v1, Flags: 10, {GetVmStatsAnswer } }
> 2013-06-28 14:22:18,465 DEBUG [cloud.server.StatsCollector]
> (StatsCollector-2:null) StorageCollector is running...
> 2013-06-28 14:22:18,476 DEBUG [cloud.server.StatsCollector]
> (StatsCollector-2:null) There is no secondary storage VM for secondary
> storage host nfs://10.147.36.75/export/secondary
> 2013-06-28 14:22:18,480 DEBUG [cloud.server.StatsCollector]
> (StatsCollector-2:null) There is no secondary storage VM for secondary
> storage host nfs://10.147.36.76/export/secondary
> 2013-06-28 14:22:18,501 DEBUG [agent.manager.ClusteredAgentAttache]
> (StatsCollector-2:null) Seq 26-927141970: Forwarding null to
> 147455086999471
>
>
>
>
>
>


-- 

N.g.U.y.e.N.A.n.H.t.U

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message