cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sheng Yang <sh...@yasker.org>
Subject Re: Test halting build every now and then
Date Wed, 12 Jun 2013 20:36:52 GMT
I tried to look into this, but it's really hard for me to reproduce it(I've
run the case for 50 times and no show of the issue).

The bash command I used is: for i in {1..50}; do mvn -Dtest=NioTest test
-pl utils; done

>From the log, it looks like server is up but client didn't connect to the
server. The correct log of whole process should be:

2013-06-12 13:30:50,079 INFO  [utils.testcase.NioTest] (main:) Test
2013-06-12 13:30:50,103 INFO  [utils.nio.NioServer]
(NioTestServer-Selector:) NioConnection started and listening on
0.0.0.0/0.0.0.0:7777
2013-06-12 13:30:50,109 INFO  [utils.nio.NioClient]
(NioTestServer-Selector:) Connecting to 127.0.0.1:7777
2013-06-12 13:30:50,351 INFO  [utils.testcase.NioTest]
(NioTestServer-Handler-1:) Server: Received CONNECT task
2013-06-12 13:30:50,388 INFO  [utils.nio.NioClient]
(NioTestServer-Selector:) SSL: Handshake done
2013-06-12 13:30:50,389 INFO  [utils.nio.NioClient]
(NioTestServer-Selector:) Connected to 127.0.0.1:7777
2013-06-12 13:30:50,389 INFO  [utils.testcase.NioTest]
(NioTestServer-Handler-1:) Client: Received CONNECT task
2013-06-12 13:30:51,406 INFO  [utils.testcase.NioTest] (main:) Client: Data
sent
2013-06-12 13:30:51,406 INFO  [utils.testcase.NioTest] (main:) Client: Data
sent
2013-06-12 13:30:51,556 INFO  [utils.testcase.NioTest]
(NioTestServer-Handler-2:) Server: Received DATA task
2013-06-12 13:30:51,597 INFO  [utils.testcase.NioTest]
(NioTestServer-Handler-3:) Server: Received DATA task
2013-06-12 13:30:51,834 INFO  [utils.testcase.NioTest]
(NioTestServer-Handler-2:) Verify done.
2013-06-12 13:30:51,856 INFO  [utils.testcase.NioTest]
(NioTestServer-Handler-3:) Verify done.
2013-06-12 13:30:52,406 INFO  [utils.testcase.NioTest] (main:) Client
stopped.
2013-06-12 13:30:52,407 INFO  [utils.testcase.NioTest] (main:) Server
stopped.

I've tried wireless network, still unable to reproduce.

Is there anything else may affect the reproducibility? I thought it was a
racy issue, but cannot prove it, since client is not up at all in your case.

--Sheng



On Wed, Jun 12, 2013 at 9:25 AM, Mike Tutkowski <
mike.tutkowski@solidfire.com> wrote:

> Hi Daan,
>
> Yeah, now that you remind me, I believe we did talk about a wireless setup
> possibly being behind this a while ago. :)
>
> When I'm working from home, I am on a wireless network.
>
> In the office, my primary connection is via cable, but I do have another
> connection to the Internet via wireless.
>
> It's not the end of the world when this problem occurs. I just CTRL-C and
> try again, but I thought if someone had a solution that perhaps I didn't
> see that I could implement it on my side.
>
> Thanks for your time!!
>
>
> On Wed, Jun 12, 2013 at 1:30 AM, Daan Hoogland <
> DHoogland@schubergphilis.com
> > wrote:
>
> > H Mike,
> >
> > I had this too, working from my home machine and got some hint on this
> > list, stating a wireless interface on your machine might be the problem.
> I
> > haven't been able to pinpoint the culprit yet. What is your setup?
> >
> > Regards,
> > Daan Hoogland
> >
> > -----Original Message-----
> > From: Mike Tutkowski [mailto:mike.tutkowski@solidfire.com]
> > Sent: woensdag 12 juni 2013 1:19
> > To: dev@cloudstack.apache.org
> > Subject: Re: Test halting build every now and then
> >
> > Took five tries to get the build over this hump a moment ago.
> >
> > Any thoughts on what's going on there?
> >
> > Thanks!
> >
> >
> > On Tue, Jun 4, 2013 at 12:22 PM, Mike Tutkowski <
> > mike.tutkowski@solidfire.com> wrote:
> >
> > > Hi,
> > >
> > > Does anyone know if there is a way to stop the build from (very often)
> > > halting here indefinitely?
> > >
> > > 2013-06-04 12:19:47,836 INFO  [utils.net.NetUtilsTest] (main:) IP is
> > > 1234:5678::dd3b:e82c:ce6b:fe5c
> > > 2013-06-04 12:19:47,839 INFO  [utils.net.NetUtilsTest] (main:) IP is
> > > 1234:5678::814a:9955:e8e2:84f Tests run: 4, Failures: 0, Errors: 0,
> > > Skipped: 0, Time elapsed: 0.085 sec Running
> > > com.cloud.utils.StringUtilsTest Tests run: 10, Failures: 0, Errors: 0,
> > > Skipped: 0, Time elapsed: 0.011 sec Running
> > > com.cloud.utils.testcase.NioTest
> > > 2013-06-04 12:19:47,860 INFO  [utils.testcase.NioTest] (main:) Test
> > > 2013-06-04 12:19:47,913 INFO  [utils.nio.NioServer]
> > > (NioTestServer-Selector:) NioConnection started and listening on
> > > 0.0.0.0/0.0.0.0:7777
> > >
> > > I usually just wait for this point in the build and if it halts, then
> > > I CTRL-C and try again.
> > >
> > > Thanks!
> > >
> > > --
> > > *Mike Tutkowski*
> > > *Senior CloudStack Developer, SolidFire Inc.*
> > > e: mike.tutkowski@solidfire.com
> > > o: 303.746.7302
> > > Advancing the way the world uses the
> > > cloud<http://solidfire.com/solution/overview/?video=play>
> > > *(tm)*
> > >
> >
> >
> >
> > --
> > *Mike Tutkowski*
> > *Senior CloudStack Developer, SolidFire Inc.*
> > e: mike.tutkowski@solidfire.com
> > o: 303.746.7302
> > Advancing the way the world uses the
> > cloud<http://solidfire.com/solution/overview/?video=play>
> > *(tm)*
> >
>
>
>
> --
> *Mike Tutkowski*
> *Senior CloudStack Developer, SolidFire Inc.*
> e: mike.tutkowski@solidfire.com
> o: 303.746.7302
> Advancing the way the world uses the
> cloud<http://solidfire.com/solution/overview/?video=play>
> *™*
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message