cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "SuichII, Christopher" <Chris.Su...@netapp.com>
Subject Re: Cannot log in to fresh install as admin
Date Tue, 18 Jun 2013 18:00:32 GMT
This is what is logged when I attempt to log in:

2013-06-18 13:59:25,450 DEBUG [cloud.api.ApiServlet] (1516814774@qtp-1413016515-4:null) ===START===
 10.61.25.162 -- POST  null
2013-06-18 13:59:25,457 DEBUG [cloud.user.AccountManagerImpl] (1516814774@qtp-1413016515-4:null)
Attempting to log in user: admin in domain 1
2013-06-18 13:59:25,457 DEBUG [server.auth.SHA256SaltedUserAuthenticator] (1516814774@qtp-1413016515-4:null)
Retrieving user: admin
2013-06-18 13:59:25,469 DEBUG [cloud.user.AccountManagerImpl] (1516814774@qtp-1413016515-4:null)
User: admin in domain 1 has successfully logged in
2013-06-18 13:59:25,491 DEBUG [cloud.api.ApiServlet] (1516814774@qtp-1413016515-4:null) ===END===
 10.61.25.162 -- POST  null
2013-06-18 13:59:25,501 DEBUG [cloud.api.ApiServlet] (1516814774@qtp-1413016515-4:null) ===START===
 10.61.25.162 -- GET  command=listCapabilities&response=json&sessionkey=bF5nZqmg1r%2F2u5NltZDSRHqz%2Fbc%3D&_=1371578368902
2013-06-18 13:59:25,520 DEBUG [cloud.api.ApiServer] (1516814774@qtp-1413016515-4:null) The
given command:listCapabilities does not exist or it is not available for user with id:2
2013-06-18 13:59:25,521 DEBUG [cloud.api.ApiServlet] (1516814774@qtp-1413016515-4:null) ===END===
 10.61.25.162 -- GET  command=listCapabilities&response=json&sessionkey=bF5nZqmg1r%2F2u5NltZDSRHqz%2Fbc%3D&_=1371578368902
2013-06-18 13:59:25,528 DEBUG [cloud.api.ApiServlet] (1516814774@qtp-1413016515-4:null) ===START===
 10.61.25.162 -- GET  command=listSwifts&response=json&sessionkey=bF5nZqmg1r%2F2u5NltZDSRHqz%2Fbc%3D&_=1371578368929
2013-06-18 13:59:25,543 DEBUG [cloud.api.ApiServer] (1516814774@qtp-1413016515-4:null) The
given command:listSwifts does not exist or it is not available for user with id:2
2013-06-18 13:59:25,544 DEBUG [cloud.api.ApiServlet] (1516814774@qtp-1413016515-4:null) ===END===
 10.61.25.162 -- GET  command=listSwifts&response=json&sessionkey=bF5nZqmg1r%2F2u5NltZDSRHqz%2Fbc%3D&_=1371578368929





On Jun 18, 2013, at 1:45 PM, "SuichII, Christopher" <Chris.Suich@netapp.com> wrote:

> I have another installation that is up and running fine, so I copied the hashed admin
password into the new installation's database an set the state to enabled. Now attempting
to log in produces this popup in the UI:
> 
> "The given command does not exist or it is not available for user"
> 
> Any thoughts?
> 
> -Chris
> 
> On Jun 18, 2013, at 11:04 AM, "SuichII, Christopher" <Chris.Suich@netapp.com> wrote:
> 
>> Nope. I just pulled, clean installed and deployed the db this morning.
>> 
>> -Chris
>> 
>> On Jun 18, 2013, at 10:58 AM, David Nalley <david@gnsa.us>
>> wrote:
>> 
>>> On Tue, Jun 18, 2013 at 10:56 AM, SuichII, Christopher
>>> <Chris.Suich@netapp.com> wrote:
>>>> I've created a fresh install of CS 4.2 with source from git, however when
I attempt to log in, the following is logged:
>>>> 
>>>> WARN  [server.auth.SHA256SaltedUserAuthenticator] (1774710861@qtp-1102259485-4:)
The stored password for admin isn't in the right format for this authenticator
>>>> INFO  [cloud.user.AccountManagerImpl] (1774710861@qtp-1102259485-4:) User
admin in domain ROOT is disabled/locked (or account is disabled/locked)
>>>> 
>>>> I handle the second issue by updating the state either in developer-prefill.sql
or in the database itself. However, I'm less knowledgeable about the password hash and salting.
Is there something I have done wrong or not set up properly?
>>>> 
>>>> Thanks,
>>>> Chris
>>> 
>>> Is this an upgrade?
>>> 
>>> --David
>> 
> 


Mime
View raw message