cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Prachi Damle <Prachi.Da...@citrix.com>
Subject RE: tests involving deploying a vm fail
Date Thu, 13 Jun 2013 17:59:07 GMT
Shane,

Can you share the management server log file?

Prachi

-----Original Message-----
From: Shane Witbeck [mailto:shane@digitalsanctum.com] 
Sent: Thursday, June 13, 2013 9:18 AM
To: dev@cloudstack.apache.org
Subject: tests involving deploying a vm fail

Hi all, 

I'm attempting to run the following:

mvn -Pdeveloper,marvin.test -Dmarvin.config=setup/dev/advanced.cfg -pl :cloud-marvin integration-test

from instructions [1]. It seems all tests involving deploying a VM fail for me [2]. I've also
tried running the /smoke/test_deploy_vm.py test in isolation and I get the following:

cloudstackAPIException: Execute cmd: asyncquery failed, due to: {errorcode : 533, errortext
: u'Unable to create a deployment for VM[User|testvm]'}

I've also noticed that if I try manually deploying a VM, it will fail unless I manually create
a "local" disk offering instead of the "shared" types that are available by default.

I'm running the management server on my mac and using devcloud2 running on vbox. This is against
latest 4.2-snapshot code.

Does someone have any pointers on why deploying a VM fails for me? 


Thanks, 
Shane


[1] https://cwiki.apache.org/confluence/display/CLOUDSTACK/Marvin+-+Testing+with+Python#Marvin-TestingwithPython-
[2] https://gist.github.com/digitalsanctum/5774980


Mime
View raw message