cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hugo Trippaers <h...@trippaers.nl>
Subject Re: On git 4.1 (4.1.1-SNAPSHOT), jetty:run fails because of database version errors
Date Fri, 28 Jun 2013 17:59:56 GMT
Hello :-)

Nice find!

I've pushed this commit to the branch:

 commit b330f2aa909d7ddc387863e0806f71964f6d5f80
Author: Hugo Trippaers <htrippaers@schubergphilis.com>
Date:   Fri Jun 28 10:57:51 2013 -0700

    CLOUDSTACK-3278 Add the 410 to 411 upgrade to the PremiumDatabaseUpgradeChecker

Can you verify if this fixes your problem?


Cheers,

Hugo

On Jun 28, 2013, at 10:39 AM, Ryan Lei <ryanlei@cht.com.tw> wrote:

> Actually, the errors happen only in non-OSS build with git 4.1
> (4.1.1-SNAPSHOT).
> 
> OSS build with git 4.1 and non-OSS build with 4.1.0 source code work fine.
> They are able to run the Upgrade40to41 or Upgrade410to411.
> 
> I have created a JIRA ticket for this issue:
> https://issues.apache.org/jira/browse/CLOUDSTACK-3278
> 
> -------------------------------------------------------------------------------------------
> Yu-Heng (Ryan) Lei, Associate Reasearcher
> Chunghwa Telecom Laboratories / Cloud Computing Laboratory
> ryanlei@cht.com.tw<https://email.cht.com.tw/owa/redir.aspx?C=-wE1FEC3G0SWYpVkiWo8SsDdf3ZqO9AIuAPTzRnFYCUi-z4YljtI_hyVKkNHfn9F1Bn-vUWJnQ4.&URL=mailto%3aryanlei%40cht.com.tw>
> or
> ryanlei750328@gmail.com
> 
> 
> 
> On Fri, Jun 28, 2013 at 4:42 PM, Ryan Lei <ryanlei@cht.com.tw> wrote:
> 
>> Hi all,
>> I was trying to use the git 4.1 branch to run non-OSS CloudStack from
>> source. My commands were:
>> 
>> (1) Put the neccessary jars in deps
>> (2) Run deps/install-non-oss.sh with success
>> (3) $ mvn clean install -DskipTests=true -Dnonoss
>> (4) $ mvn -P developer -pl developer -Ddeploydb
>> (5) $ mvn -pl :cloud-client-ui jetty:run
>> 
>> Then I got these DB version errors which made the jetty quit:
>> INFO  [utils.component.ComponentContext] (Timer-2:) Running
>> SystemIntegrityChecker encryptionSecretKeyChecker
>> INFO  [utils.component.ComponentContext] (Timer-2:) Running
>> SystemIntegrityChecker databaseIntegrityChecker
>> INFO  [cloud.upgrade.DatabaseIntegrityChecker] (Timer-2:) Grabbing lock to
>> check for database integrity.
>> INFO  [cloud.upgrade.DatabaseIntegrityChecker] (Timer-2:) Performing
>> database integrity check
>> INFO  [utils.component.ComponentContext] (Timer-2:) Running
>> SystemIntegrityChecker managementServerNode
>> INFO  [utils.component.ComponentContext] (Timer-2:) Running
>> SystemIntegrityChecker premiumDatabaseUpgradeChecker
>> INFO  [cloud.upgrade.DatabaseUpgradeChecker] (Timer-2:) Grabbing lock to
>> check for database upgrade.
>> INFO  [cloud.upgrade.DatabaseUpgradeChecker] (Timer-2:) DB version = 4.0.0
>> Code Version = 4.1.1-SNAPSHOT
>> INFO  [cloud.upgrade.DatabaseUpgradeChecker] (Timer-2:) Database upgrade
>> must be performed from 4.0.0 to 4.1.1-SNAPSHOT
>> ERROR [cloud.upgrade.DatabaseUpgradeChecker] (Timer-2:) The end upgrade
>> version is actually at 4.1.0 but our management server code version is at
>> 4.1.1-SNAPSHOT
>> ERROR [utils.component.ComponentContext] (Timer-2:) System integrity check
>> failed. Refuse to startup
>> 
>> 
>> In MySQL, I found the table in 'version' has only one entry whose value is
>> 4.0.0.
>> Manually modifying the value to 4.1.1 led to other exceptions. Looks like
>> 4.1 git "forgets" to upgrade the database.
>> 
>> Is this a bug in the current 4.1 branch?
>> 
>> 
>> -------------------------------------------------------------------------------------------
>> Yu-Heng (Ryan) Lei, Associate Reasearcher
>> Chunghwa Telecom Laboratories / Cloud Computing Laboratory
>> ryanlei@cht.com.tw<https://email.cht.com.tw/owa/redir.aspx?C=-wE1FEC3G0SWYpVkiWo8SsDdf3ZqO9AIuAPTzRnFYCUi-z4YljtI_hyVKkNHfn9F1Bn-vUWJnQ4.&URL=mailto%3aryanlei%40cht.com.tw>
or
>> ryanlei750328@gmail.com
>> 
>> 


Mime
View raw message