cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Laszlo Hornyak" <laszlo.horn...@gmail.com>
Subject Re: Review Request 11980: FileUtil simplified
Date Thu, 27 Jun 2013 06:30:09 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/11980/
-----------------------------------------------------------

(Updated June 27, 2013, 6:30 a.m.)


Review request for cloudstack.


Changes
-------

added Assume to avoid failing the test on non-linux OS's


Repository: cloudstack-git


Description
-------

- writeToFile removed since no references to it
- readFileAsString replaced with FileUtils.readFileToString
- minor code duplication removed in dependent method getNicStats
- unit test added


Diffs (updated)
-----

  plugins/hypervisors/kvm/src/com/cloud/hypervisor/kvm/resource/LibvirtComputingResource.java
b1bc99d 
  plugins/hypervisors/kvm/test/com/cloud/hypervisor/kvm/resource/LibvirtComputingResourceTest.java
c82c31f 
  utils/src/com/cloud/utils/FileUtil.java 74f4088 

Diff: https://reviews.apache.org/r/11980/diff/


Testing
-------

test included


Thanks,

Laszlo Hornyak


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message