cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Prasanna Santhanam <...@apache.org>
Subject Re: RPM building tests in jenkins
Date Mon, 03 Jun 2013 16:10:04 GMT
On Fri, May 31, 2013 at 04:58:45AM -0400, David Nalley wrote:
> On Fri, May 31, 2013 at 2:59 AM, Prasanna Santhanam <tsp@apache.org> wrote:
> > On Thu, May 30, 2013 at 10:51:12AM -0400, David Nalley wrote:
> >> Hi folks:
> >>
> >> I came across an interesting problem today, and think it's one that
> >> deserves fixing.
> >>
> >> I looked at our jenkins config and found that we build packages in a
> >> manner that is different from how our documentation tells users to
> >> build those packages. IMO while there may be more than one way to skin
> >> the cat, we should at least be testing the manner we tell others to
> >> use. (or perhaps changing the method we tell users to use to match the
> >> tests we are doing)
> >>
> >> Such disconnects between how our user base consumes ACS and how we
> >> test it is bound to cause us problems.
> >>
> >
> > What was different? The package.sh script in our repo was modified to
> > take options but performs the same steps as does the package job on
> > jenkins.  We only write the full complete `rpmbuild` command on our
> > jenkins job.
> >
> 
> How do you know they will always remain the same?
> Being the same is not the point - we aren't testing the way we tell
> users to do it. We wouldn't know if the way we tell users is broken or
> not, because we aren't exercising that path. One of them needs to
> change so that they are the same - even if they are the same in
> effect.
> 

Oh I fixed this btw. we're in sync with docs now.

-- 
Prasanna.,

------------------------
Powered by BigRock.com


Mime
View raw message