cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ahmad Emneina <aemne...@gmail.com>
Subject Re: 4.2 snapshot: setting up ISOs - no go
Date Wed, 29 May 2013 23:09:56 GMT
also, when trying to add the iso, can you capture the output in the ssvms'
cloud.out or cloud.log (cant remember which). It would be interesting to
see whats happening on the ssvm side of things.


On Wed, May 29, 2013 at 2:41 PM, Edison Su <Edison.su@citrix.com> wrote:

> Can you try:
> select status from host where type = 'SecondaryStorageVM';
> in db?
>
> Make sure the agent in ssvm can connect back to mgt serer.
>
> > -----Original Message-----
> > From: La Motta, David [mailto:David.LaMotta@netapp.com]
> > Sent: Wednesday, May 29, 2013 2:28 PM
> > To: <dev@cloudstack.apache.org>
> > Subject: 4.2 snapshot: setting up ISOs - no go
> >
> > So my 4.2 instance is up and running, system VMs are running (secondary
> > storage VM and console proxy VM), primary and secondary storage are up
> > on NFS... all things considered and at a glance, things look good.
>  However,
> > when I try to add an ISO so that I can provision a VM, I am getting:
> >
> > WARN  [storage.download.DownloadMonitorImpl] (1018141210@qtp-
> > 2013781391-38:) There is no secondary storage VM for secondary storage
> > host nfs://172.20.39.74/SnapCreator_secondary
> >
> > Which is throwing me off, because the secondary storage VM seems to be
> > up and happy.  I can see it on XenCenter alive and well, too.  When I go
> > through the ISO registration wizard, registration seems to be successful
> in
> > the UI, since the ISOs get added to the templates table--except I get the
> > warning in the console above.
> >
> > If I try to add another secondary storage, I get:
> >
> > ERROR [cloud.api.ApiServer] (1260872222@qtp-2013781391-40:) unhandled
> > exception executing api command: addSecondaryStorage
> > com.cloud.utils.exception.CloudRuntimeException: Cannot transit agent
> > status with event AgentDisconnected for host 9, mangement server id is
> > 271423992217301,Unable to transition to a new state from Creating via
> > AgentDisconnected at
> > com.cloud.agent.manager.AgentManagerImpl.agentStatusTransitTo(Agent
> > ManagerImpl.java:1436)
> >
> >
> > When in doubt, reboot, right?  So I shutdown my CS mgmt server and
> > XenServer host and tried again.  I even added more secondary storage
> > without anything in it (the first NFS volume had the system VM template
> on
> > it).  Still, I get the same behavior as described above:  the UI says
> the ISO was
> > added, but the log file warns about the lack of a secondary storage VM.
> >
> > If I attempt to go through the instance provisioning wizard, long and
> behold,
> > the ISO is not listed in the "My ISOs" tab.
> >
> >
> > There is also something strange that I've noticed (slightly off topic):
> if I have
> > primary storage allocated and resize the underlying volume on the storage
> > controller, CS doesn't see the new size.  Is there any way to force that
> to take
> > place from the UI?  Clicking on refresh did nothing about it.
> >
> > Thanks!
> >
> >
> >
> > David La Motta
> > Technical Marketing Engineer - Citrix
> >
> > NetApp
> > 919.476.5042
> > dlamotta@netapp.com<mailto:dlamotta@netapp.com>
> >
> >
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message