cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcus Sorensen <shadow...@gmail.com>
Subject Re: [jira] [Commented] (CLOUDSTACK-2110) All Nics of VM are not getting IP when adding multiple nics to a VM
Date Thu, 02 May 2013 14:22:07 GMT
Yes, I thought I sent out a patch request, but I may have typed something.
This patch is good to have anyway, because it can trigger other bugs.
Namely, the line it fixes can currently accidentally delete dhcp entries
for VMs that end in the name of the VM being passed in. So a server called
"web1" would wipe out the dhcp entry for a server called "internalweb1". I
will see if this applies to 4.0 as well.
On May 2, 2013 8:16 AM, "Chip Childers (JIRA)" <jira@apache.org> wrote:

>
>     [
> https://issues.apache.org/jira/browse/CLOUDSTACK-2110?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13647559#comment-13647559]
>
> Chip Childers commented on CLOUDSTACK-2110:
> -------------------------------------------
>
> marcus - should I just pull this into 4.1?  We can resolve the bug once
> it's over in 4.1, and only *close* it after confirmation.
>
> > All Nics of VM are not getting IP when adding multiple nics to a VM
> > -------------------------------------------------------------------
> >
> >                 Key: CLOUDSTACK-2110
> >                 URL:
> https://issues.apache.org/jira/browse/CLOUDSTACK-2110
> >             Project: CloudStack
> >          Issue Type: Bug
> >      Security Level: Public(Anyone can view this level - this is the
> default.)
> >          Components: Network Controller
> >    Affects Versions: 4.1.0, 4.2.0
> >         Environment: xen hypervisor advanced zone
> > Build:
> > CloudStack-non-OSS-MASTER-232-rhel6.3
> >            Reporter: shweta agarwal
> >            Priority: Blocker
> >             Fix For: 4.1.0, 4.2.0
> >
> >
> > Repro steps:
> > 1.Create a VM
> > 2. Create several Network
> > 3. add all the network created in step 2 via add nic cmd
> > 4. reboot VM
> > Bug:
> > All eths don't gets IP . some of them failed
> > Expected Behavior:
> > All eths should get IP .
> > Additional info:
> > Even after doing network restart or dhcpclient also those eths are not
> getting IP.
> > When we stop /start VM  some of the eths gets ip some still fails.
> > Investigating more on this scenario to narrow down to specific case.
> However filed it so that somebody can take  a look of the bug.
> > Db shows Ip is assigned to all nics:
> > "id"  "uuid"  "instance_id"   "mac_address"   "ip4_address"   "netmask"
>       "gateway"       "ip_type"       "broadcast_uri" "network_id"
>  "mode"  "state" "strategy"      "reserver_name" "reservation_id"
>  "device_id"     "update_time"   "isolation_uri" "ip6_address"
> "default_nic"   "vm_type"       "created"       "removed"
> "ip6_gateway"   "ip6_cidr"      "secondary_ip"
> > "8"   "779399c2-b1f8-4a5a-95d2-373ee1c97cc4"  "3"
> "02:00:18:18:00:01"     "10.1.1.194"    "255.255.255.0" "10.1.1.1"
>  "Ip4"   "vlan://1049"   "204"   "Dhcp"  "Reserved"      "Start"
> "ExternalGuestNetworkGuru"      "84246f21-a495-47d4-8f06-cf7ff422f8a1"  "0"
>     "2013-04-19 09:26:39"   "vlan://1049"   NULL    "1"     "User"
>  "2013-04-19 11:09:10"   NULL    NULL    NULL    "0"
> > "20"  "18941cd8-5511-4fb5-bd70-6876fe47e91e"  "3"
> "06:f1:18:00:00:29"     "10.147.51.130" "255.255.255.0" "10.147.51.1"
> "Ip4"   "vlan://51"     "207"   "Dhcp"  "Reserved"      "Create"
>  "DirectNetworkGuru"     NULL    "2"     "2013-04-19 09:27:04"
> "vlan://51"     NULL    "0"     "User"  "2013-04-19 11:26:07"   NULL
>  NULL    NULL    "0"
> > "24"  "d328b70d-86ad-45fc-8273-aefc6465d226"  "3"
> "02:00:58:64:00:03"     "10.1.1.67"     "255.255.255.0" "10.1.1.1"
>  "Ip4"   "vlan://1049"   "204"   "Dhcp"  "Reserved"      "Start"
> "ExternalGuestNetworkGuru"      "84246f21-a495-47d4-8f06-cf7ff422f8a1"  "3"
>     "2013-04-19 09:27:16"   "vlan://1049"   NULL    "0"     "User"
>  "2013-04-19 11:33:14"   NULL    NULL    NULL    "0"
> > "25"  "c63fc0bf-f6ab-4753-acbb-a14770886719"  "3"
> "02:00:0e:c3:00:04"     "10.1.1.250"    "255.255.255.0" "10.1.1.1"
>  "Ip4"   "vlan://1049"   "204"   "Dhcp"  "Reserved"      "Start"
> "ExternalGuestNetworkGuru"      "84246f21-a495-47d4-8f06-cf7ff422f8a1"  "4"
>     "2013-04-19 09:27:28"   "vlan://1049"   NULL    "0"     "User"
>  "2013-04-19 11:33:56"   NULL    NULL    NULL    "0"
> > "29"  "d42b3a7f-8e8c-4712-99e9-786197ef8fb1"  "3"
> "02:00:00:01:00:08"     "10.1.1.171"    "255.255.255.0" "10.1.1.1"
>  "Ip4"   "vlan://1049"   "204"   "Dhcp"  "Reserved"      "Start"
> "ExternalGuestNetworkGuru"      "84246f21-a495-47d4-8f06-cf7ff422f8a1"  "6"
>     "2013-04-19 09:27:52"   "vlan://1049"   NULL    "0"     "User"
>  "2013-04-19 13:20:22"   NULL    NULL    NULL    "0"
> > "30"  "444a6520-c86d-48ea-91d2-d9bd73902812"  "3"
> "02:00:19:2d:00:01"     "10.1.1.60"     "255.255.255.0" "10.1.1.1"
>  "Ip4"   "vlan://1043"   "209"   "Dhcp"  "Deallocating"  "Start"
> "ExternalGuestNetworkGuru"      NULL    "7"     "2013-04-19 09:34:33"
> "vlan://1043"   NULL    "0"     "User"  "2013-04-19 13:30:19"   "2013-04-19
> 13:34:33"   NULL    NULL    "0"
> > "34"  "bbd0a8b0-1913-4306-8b4d-45750bf52c27"  "3"
> "02:00:56:37:00:01"     "10.1.1.192"    "255.255.255.0" "10.1.1.1"
>  "Ip4"   "vlan://1050"   "208"   "Dhcp"  "Deallocating"  "Start"
> "ExternalGuestNetworkGuru"      NULL    "8"     "2013-04-19 09:34:33"
> "vlan://1050"   NULL    "0"     "User"  "2013-04-19 13:31:13"   "2013-04-19
> 13:34:33"   NULL    NULL    "0"
> > "38"  "170bb5af-b355-4cb4-8376-490d3e032f80"  "3"
> "02:00:07:af:00:03"     "10.1.1.35"     "255.255.255.0" "10.1.1.1"
>  "Ip4"   "vlan://1044"   "206"   "Dhcp"  "Deallocating"  "Start"
> "ExternalGuestNetworkGuru"      NULL    "9"     "2013-04-19 09:34:09"
> "vlan://1044"   NULL    "0"     "User"  "2013-04-19 13:31:33"   "2013-04-19
> 13:34:09"   NULL    NULL    "0"
> > "39"  "ae94bf81-a369-4e7c-b5ee-4c76e96c1236"  "3"
> "06:ad:24:00:00:23"     "10.147.51.124" "255.255.255.0" "10.147.51.1"
> "Ip4"   "vlan://51"     "207"   "Dhcp"  "Deallocating"  "Create"
>  "DirectNetworkGuru"     NULL    "10"    "2013-04-19 09:34:10"
> "vlan://51"     NULL    "0"     "User"  "2013-04-19 13:31:58"   "2013-04-19
> 13:34:10"   NULL    NULL    "0"
> > VM shows no ip:
> > eth3      Link encap:Ethernet  HWaddr 02:00:58:64:00:03
> > UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
> > RX packets:505 errors:0 dropped:0 overruns:0 frame:0
> > TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
> > collisions:0 txqueuelen:1000
> > RX bytes:29910 (29.2 KiB)  TX bytes:1710 (1.6 KiB)
> > eth4      Link encap:Ethernet  HWaddr 02:00:0E:C3:00:04
> > UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
> > RX packets:485 errors:0 dropped:0 overruns:0 frame:0
> > TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
> > collisions:0 txqueuelen:1000
> > RX bytes:23970 (23.4 KiB)  TX bytes:2052 (2.0 KiB)
>
> --
> This message is automatically generated by JIRA.
> If you think it was sent incorrectly, please contact your JIRA
> administrators
> For more information on JIRA, see: http://www.atlassian.com/software/jira
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message