cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ryan Lei <ryanlei750...@gmail.com>
Subject Re: [jira] [Commented] (CLOUDSTACK-2702) unable to install XenServer Support Package (CSP) on Xen cloud platform 1.6
Date Wed, 29 May 2013 03:03:09 GMT
As I just tested, I was unable to install any of these support packages for
XCP 1.1.

# xe-install-supplemental-pack xenserver-cloud-supp.iso
Error: Repository is not compatible with installed product (XenServer
expected)
Do you want to continue? (Y/N) y
Error: unsatisfied dependency xs:main eq 6.0.0
Do you want to continue? (Y/N) y
Installing 'XenServer Cloud Supp Pack'...

error: Failed dependencies:
        kernel-xen = 2.6.32.12-0.7.1.xs6.0.0.529.170661 is needed by
ipset-modules-xen-2.6.32.12-0.7.1.xs6.0.0.529.170661-4.5-1.xs32.i686
        kernel-xen = 2.6.32.12-0.7.1.xs6.0.0.529.170661 is needed by
ipset-modules-kdump-2.6.32.12-0.7.1.xs6.0.0.529.170661-4.5-1.xs32.i686
./install.sh: line 308: /etc/firstboot.d/99-XenServer-CSP-setup: No such
file or directory
FATAL: packages failed to install

Does that mean security groups for basic zone + XCP is ONLY supported for
XCP 1.6 (requiring CS 4.1 also), where the support package (CSP) is built
in?



On Wed, May 29, 2013 at 10:37 AM, Ryan Lei <ryanlei750328@gmail.com> wrote:

> May I also ask what versions of CSP should I install for XCP 1.1 and XCP
> 1.5 beta?
> Current documentation points to sources for 3 XenServer versions:
>
> For XenServer 6.0.2:
> http://download.cloud.com/releases/3.0.1/XS-6.0.2/xenserver-cloud-supp.tgz
>
> For XenServer 6.0:
>  http://download.cloud.com/releases/3.0/xenserver-cloud-supp.tgz
>
> For XenServer 5.6 SP2:
> http://download.cloud.com/releases/2.2.0/xenserver-cloud-supp.tgz
>
> Thanks
>
>
> On Wed, May 29, 2013 at 12:24 AM, Prasanna Santhanam <tsp@apache.org>wrote:
>
>> On Tue, May 28, 2013 at 01:52:20PM +0000, Dean Kamali (JIRA) wrote:
>> >
>> >     [
>> https://issues.apache.org/jira/browse/CLOUDSTACK-2702?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13668307#comment-13668307]
>> >
>> > Dean Kamali commented on CLOUDSTACK-2702:
>> > -----------------------------------------
>> >
>> > According to  http://cloudstack.apache.org/  CloudStack currently
>> > supports the most popular hypervisors: VMware, KVM, XenServer and
>> > Xen Cloud Platform (XCP).
>> >
>> > Is XCP is not fully supported?
>>
>> The packages (ipset, ebtables etc) that come with the CSP are included
>> in XenServer since 6.1. Similar instructions should work for XCP
>> although I haven't tried it myself. The one step I do remember to
>> enable security groups was to switch network backend to bridge.
>>
>> Rest of the functionality should be out of the box. If not there's
>> probably some sysctl settings that can be tweaked.
>>
>>
>> --
>> Prasanna.,
>>
>> ------------------------
>> Powered by BigRock.com
>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message