cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kishan Kavala <Kishan.Kav...@citrix.com>
Subject RE: [ACS41] Release Blocker Update for 2013-05-08
Date Fri, 10 May 2013 12:17:49 GMT


> -----Original Message-----
> From: Sebastien Goasguen [mailto:runseb@gmail.com]
> Sent: Friday, 10 May 2013 3:28 PM
> To: dev@cloudstack.apache.org
> Subject: Re: [ACS41] Release Blocker Update for 2013-05-08
> 
> 
> On May 10, 2013, at 2:47 AM, Kishan Kavala <Kishan.Kavala@citrix.com>
> wrote:
> 
> >
> >
> >> -----Original Message-----
> >> From: Sebastien Goasguen [mailto:runseb@gmail.com]
> >> Sent: Thursday, 9 May 2013 9:45 PM
> >> To: dev@cloudstack.apache.org
> >> Subject: Re: [ACS41] Release Blocker Update for 2013-05-08
> >>
> >>
> >> On May 9, 2013, at 8:54 AM, Kishan Kavala <Kishan.Kavala@citrix.com>
> wrote:
> >>
> >>>
> >>>
> >>>> -----Original Message-----
> >>>> From: Chip Childers [mailto:chip.childers@sungard.com]
> >>>> Sent: Wednesday, 8 May 2013 10:48 PM
> >>>> To: dev@cloudstack.apache.org
> >>>> Cc: Kishan Kavala
> >>>> Subject: [ACS41] Release Blocker Update for 2013-05-08
> >>>>
> >>>> Here's where we stand:
> >>>>
> >>>> CLOUDSTACK-2309
> >>>> Upgrade from 2.2.14 to 4.1.0 : network static routes deleted on
> >>>> SSVM
> >>>>
> >>>> Kishan - any update on 2309?  Also note that Wei suggested a fix to
> >>>> the  reporter for 528.  However, you said you thought 2309 and 528
> >>>> could be  related.  Can you review the suggestion?
> >>>>
> >>> Chip,
> >>> I successfully upgraded from 2.2.14 to 4.1 . SSVM came up after
> >>> stopping
> >> and starting. All the routes were also properly configured.
> >>> I'll work with Nicolas to see if all the upgrades steps were followed.
> >>>
> >>> Routes won't be configured if SecStorageVMSetupCommand is not sent
> >>> to
> >> SSVM.
> >>>
> >>> ~kishan
> >>>
> >>
> >> Kishan, which hypervisor and OS did you use
> >>
> >> thanks
> >>
> >> -sebastien
> >>
> > [KK]  Sebastien, I tested it on XenServer/RHEL6.2.
> >
> Any chance to test with vshpere/esx

I tested with Vmware today and found few issues:

1. Code to handle new VmWare template as per release notes is missing.

I fixed this in master and submitted patch for 4.1. Patch request [1]
Fix should go into 4.0 branch as well.

2.  MS failed to start after upgrading with error:

Starting cloudstack-management: sed: can't read /usr/share/cloudstack-management/conf/server.xml:
No such file or directory
/etc/rc.d/init.d/tomcat6: line 191: /var/log/cloudstack-management/initd.log: No such file
or directory
Error code 4                                               [FAILED]

Filed bug: CLOUDSTACK-2440

3. Ran into CLOUDSTACK-2064 while restarting SSVM after upgrade. I had to manually change
permissions for cloud user to make it work.

With the fix and workarounds ,  SSVM started without any issues and the routes were are also
setup.

 [1] https://reviews.apache.org/r/11042/


Mime
View raw message