cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rajesh Battala <rajesh.batt...@citrix.com>
Subject RE: Review Request: Fixed CLOUDSTACK-2662 Preferred implicit dedication fails with insufficient capacity even if shared hosts are available.
Date Thu, 30 May 2013 11:28:09 GMT
Additional Tests Cases executed :


1.      Deploy setup with only one host.

Enabling zone will create sys vms on the host and it will be marked as Shared.

Deploy VM from the account with Implict preferred. It will try in strict and then tried Shared
and created instance in the available single host.

Thanks
Rajesh Battala



From: Rajesh Battala [mailto:noreply@reviews.apache.org] On Behalf Of Rajesh Battala
Sent: Thursday, May 30, 2013 4:53 PM
To: Prachi Damle; Devdeep Singh
Cc: Rajesh Battala; cloudstack
Subject: Re: Review Request: Fixed CLOUDSTACK-2662 Preferred implicit dedication fails with
insufficient capacity even if shared hosts are available.

This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/11510/


Review request for cloudstack, Devdeep Singh and Prachi Damle.
By Rajesh Battala.

Updated May 30, 2013, 11:22 a.m.

Changes

incorporate review comments.


Description

Issues:

In Implicit planner resource usage is fixed to "Dedicated". It should be Dedicated/Shared
depending upon the Implict Planner strict/preferred modes and hosts availability.



Fixed:

Issue is fixed by determining the resource usage to be "Dedicated/Shared" depending upon the
Implicit strict/preferred mode and the hosts availability for the planner.


Testing

Test Cases Executed Manually :



Accounts : Admin, TestA, TestB

2 Clusters, 3 Hosts. (HostA, HostB, HostC)



When zone is enabled.

In HostA , ssvm, cpvm had came up and this resource is marked as Shared.



1. login to TestA, create Vm with implict Strict.

   routerVm for TestA came on HostB (marked as Shared) and instance came up on HostC ( Marked
as Dedicated)

2. from TestA, deploy a VM with implict Preffered.

   VM successfuly deployed on the HostC. (as its possible to deploy in strict mode, VM got
deployed on HostC)

3. login to TestB,

   Create VM with Implict Strcit.Creation of Vm failed successfuly ( as there are no empty
hosts)

   Create VM with Implict Preferred. router VM created on HostB. Instance got deployed on
HostB. (tried Dedicated as there are no empty hosts, tired with Shared and deployed on HostB)

   Create VM with Implict Preferred, deployVm. instance got created on HostA.( Tried Dedicated
and then tried shared. As HostA is marked as Shared VM got deployed on HostA)

  from TestB account two Vm's got deployed, with implict preferred mode. VM's were successfully
deployed on the Hosts which are marked as Shared.

4. Removed the VM's deployed from TestA and Router for the TestA.

   HostC now unmarked as 'Dedicated'

5. Login to TestB,

   Deploy Vm with Implict preferred. VM got deployed on HostC ( tried strict as empty HostC
is available, VM deployed in HostC). HostC marked as "Dedicated"

   Deploy Vm with Implict Strict. VM got deployed on HostC. (As dedicated host is available
because of above deployement. Vm got successfuly deployed on HostC)



6. Login as Admin

   deploy vm with "medium instance" offering. VM got deployed in shared resource host.

Bugs: CLOUDSTACK-2662
Diffs (updated)

  *   api/src/com/cloud/deploy/DeploymentClusterPlanner.java (1a19c71)
  *   plugins/deployment-planners/implicit-dedication/src/com/cloud/deploy/ImplicitDedicationPlanner.java
(d47d8f5)
  *   server/src/com/cloud/deploy/DeploymentPlanningManagerImpl.java (d954c8b)
  *   server/src/com/cloud/deploy/FirstFitPlanner.java (caf8c6e)

View Diff<https://reviews.apache.org/r/11510/diff/>

Screenshots
[mysql_data_xencenter_view]<https://reviews.apache.org/r/11510/s/26/>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message