cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rajesh Battala <rajesh.batt...@citrix.com>
Subject RE: Unable to start System VM's in KVM Failing with error Domain is Tainted with high-privilages
Date Tue, 21 May 2013 08:55:23 GMT
This issue I saw while looking at the logs for the issue https://issues.apache.org/jira/browse/CLOUDSTACK-2330
[[Automation] Failed to deploy VR in KVM].

Build/Code is from the latest master branch. Latest system templates are used. 

Thanks
Rajesh Battala


> -----Original Message-----
> From: Prasanna Santhanam [mailto:tsp@apache.org]
> Sent: Tuesday, May 21, 2013 2:10 PM
> To: dev@cloudstack.apache.org
> Subject: Re: Unable to start System VM's in KVM Failing with error Domain is
> Tainted with high-privilages
> 
> On Tue, May 21, 2013 at 08:22:54AM +0000, Rajesh Battala wrote:
> > Hi All,
> >
> > When SystemVM's are coming up in KVM, they are getting shutoff with
> > error.
> >
> > What could be reason to mark the VM as tainted.
> If we do custom qemu options, apparently -
> https://www.berrange.com/tags/tainting/
> 
> 
> > Libvirt.log:
> > =====
> > 2013-05-04 07:03:54.035+0000: 26209: warning :
> > qemuDomainObjTaint:1297 : Domain id=2 name='r-6-VM'
> > uuid=5b34a307-7433-3ae8-b172-87a5668e193b is tainted:
> > high-privileges
> 
> What's in the libvirt log below these warnings?
> 
> >
> >
> > r-6-vm.log: (guest log)
> > ==================
> > 2013-05-04 07:03:54.034+0000: starting up
> > LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin QEMU_AUDIO_DRV=none
> /usr/libexec/qemu-kvm -S -M rhel6.3.0 -enable-kvm -m 128 -smp
> 1,sockets=1,cores=1,threads=1 -name r-6-VM -uuid 5b34a307-7433-3ae8-
> b172-87a5668e193b -nodefconfig -nodefaults -chardev
> socket,id=charmonitor,path=/var/lib/libvirt/qemu/r-6-
> VM.monitor,server,nowait -mon
> chardev=charmonitor,id=monitor,mode=control -rtc base=utc -no-shutdown
> -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device virtio-serial-
> pci,id=virtio-serial0,bus=pci.0,addr=0x6 -drive file=/mnt/fff90cb5-06dd-33b3-
> 8815-d78c08ca01d9/5b1702c1-ddb8-4ed3-b24b-
> ed1bea5ec300,if=none,id=drive-virtio-disk0,format=qcow2,cache=none -
> device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x7,drive=drive-virtio-
> disk0,id=virtio-disk0,bootindex=2 -drive file=/usr/share/cloudstack-
> common/vms/systemvm.iso,if=none,media=cdrom,id=drive-ide0-1-
> 0,readonly=on,format=raw,cache=none -device ide-
> drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0,bootindex=1 -netdev
> tap,fd=27,id=hostnet0,vhost=on,vhostfd=29 -device virtio-net-
> pci,netdev=hostnet0,id=net0,mac=02:00:4c:23:00:02,bus=pci.0,addr=0x3 -
> netdev tap,fd=30,id=hostnet1,vhost=on,vhostfd=31 -device virtio-net-
> pci,netdev=hostnet1,id=net1,mac=0e:00:a9:fe:01:04,bus=pci.0,addr=0x4 -
> netdev tap,fd=32,id=hostnet2,vhost=on,vhostfd=33 -device virtio-net-
> pci,netdev=hostnet2,id=net2,mac=06:c5:2c:00:00:3f,bus=pci.0,addr=0x5 -
> chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -
> chardev socket,id=charchannel0,path=/var/lib/libvirt/qemu/r-6-
> VM.agent,server,nowait -device virtserialport,bus=virtio-
> serial0.0,nr=1,chardev=charchannel0,id=channel0,name=r-6-VM.vport -device
> usb-tablet,id=input0 -vnc 0.0.0.0:1 -vga cirrus -device virtio-balloon-
> pci,id=balloon0,bus=pci.0,addr=0x8
> > Domain id=2 is tainted: high-privileges
> > char device redirected to /dev/pts/1
> > qemu: terminating on signal 15 from pid 26206
> > 2013-05-04 13:57:11.189+0000: shutting down
> >
> Does it happen only with routers?
> 
> Sounds like you should file a bug with  details like:
> 1. are you using the latest systemvm templates?
> 2. which branch you are facing this on? master?
> 
> --
> Prasanna.,
> 
> ------------------------
> Powered by BigRock.com


Mime
View raw message