cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aaron Paradowski <>
Subject RE: DevCloud
Date Thu, 18 Apr 2013 18:40:32 GMT

I tried again. This time between steps 8 and 9 I ran the following command

export MAVEN_OPTS="-Xmx1024m -XX:MaxPermSize=800m -Xdebug -Xrunjdwp:transport=dt_socket,address=8787,server=y,suspend=n"

It still hung again after running the mvn-pl client jetty:run command - see below. The command
is still running so I am unable to do anything else unless I cancel it. Any ideas? Thanks
in advance for your help again.



From: [] On Behalf Of Rohit Yadav
Sent: 18 April 2013 18:51
To: Aaron Paradowski
Subject: Re: DevCloud

On Thu, Apr 18, 2013 at 10:17 PM, Aaron Paradowski <<>>
Hi Rohit,

I'm having some problems deploying DevCloud2 and wonder if you could help please. So far I
have done the following

1.       Downloaded and imported the DevCloud2 image into VirtualBox - ensured network settings
were correct etc.

2.       Used PuTTY to SSH to the machine at and logged in with root and password
for username and password

3.       cd to /opt/cloudstack

4.       git cloned into the source code for incubator cloudstack

5.       once that had completed I cd'd to the incubator-cloudstack directory

6.       Ran mvn clean install -P developer,systemvm

7.       Changedthe host value in devcloud.sql to as I want everything to run
inside this one VM

8.       Ran mvn -pl developer,tools/devloud -Deploydb -P developer

Hi Aaron,

The best way is to reach to the whole community and cc any particular person whose attention
you may be seeking.

1-8: So far so good, ignoring the -Ddeploydb typo.

9.       Then ran mvn-pl client jetty:run and this is where everything goes wrong. It hangs
on the below screen for ages then it goes through lots of warnings and errors such as "WARN
[apache.cloudstack.alerts] (HA-3:) alertType:: 13" - I left it for 19 hours overnight last
night and those types of errors just kept going round in cycles?
Looks like CloudStack issue? Did you try exporting maven opts, checkout the building on master
on<> / cloudstack and try again?

If you're just able to login inside DevCloud2 and run something like xe vm-list and it outputs
something we're good at least from DevCloud's side :)

Anyone from community?


Any help would be greatly appreciated! Many thanks in advance.

Kind Regards,

Aaron Paradowski

  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message