cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rohit Yadav <bhais...@apache.org>
Subject Re: no tinyLinux template
Date Fri, 19 Apr 2013 19:34:21 GMT
On Fri, Apr 19, 2013 at 11:18 PM, Edison Su <Edison.su@citrix.com> wrote:

> The default ttylinux template does not pre-installed in latest devcloud2
> virtualbox image, and the system vm can't access public network, thus,
> can't download tty template.
> Either it should be fixed by Rohit and upload an new image to his
> devcloud2 link(
> http://people.apache.org/~bhaisaab/cloudstack/devcloud/devcloud2.ova), or
> provides a way to generate devcloud virtualbox image automatically in
> Jenkins.
>


/me facepalm

DevCloud2 (from the stated url) contains ttylinux. It's a known issue that
vms cannot reach out to the public network in DevCloud2, so I had already
pre-seeded tiny linux template in /opt/storage/secondary/... (you can
confirm the same). It works for me, it must be some other issue?

Cheers.


>
> > -----Original Message-----
> > From: Chiradeep Vittal [mailto:Chiradeep.Vittal@citrix.com]
> > Sent: Friday, April 19, 2013 9:51 AM
> > To: dev@cloudstack.apache.org
> > Subject: Re: no tinyLinux template
> >
> > FWIW, I always revert to the initial snapshot of devcloud2 before
> switching
> > contexts.
> > You should also check
> > select * from template_host_ref where template_id = 5;
> >
> > And inside DevCloud2
> > ls /opt/secondary/template/tmpl/1/5/
> >
> > And, inside the SSVM
> > ps -ef | grep java
> >
> >
> > On 4/18/13 9:54 PM, "Mike Tutkowski" <mike.tutkowski@solidfire.com>
> > wrote:
> >
> > >It's strange...I deleted my entire cloud and re-created it this way:
> > >
> > >mvn -pl developer,tools/devcloud -Ddeploydb -P developer
> > >
> > >cd tools/devcloud ; python ../marvin/marvin/deployDataCenter.py -i
> > >devcloud.cfg
> > >
> > >but still no tinyLinux template (even though it is in the
> > >cloud.vm_template table).
> > >
> > >
> > >On Thu, Apr 18, 2013 at 10:05 PM, Mike Tutkowski <
> > >mike.tutkowski@solidfire.com> wrote:
> > >
> > >> Here is what I used to deploy the DB:
> > >>
> > >> mvn -pl developer,tools/devcloud -Ddeploydb -P developer
> > >>
> > >> Also, cloud.vm_template has this row:
> > >>
> > >> '5', 'tiny Linux', 'tiny Linux',
> > >>'2a182234-a87b-11e2-84ee-e322fe93e6c9',
> > >> '1', '1', 'BUILTIN', '0', '64', '
> > >> http://people.apache.org/~bhaisaab/vms/ttylinux_pv.vhd', 'VHD',
> > >> '2013-04-18 16:56:11', NULL, '1', '046e134e642e6d344b34648223ba4bc1',
> > >>'tiny
> > >> Linux', '0', '0', '12', '1', '0', '1', '1', 'XenServer', NULL, NULL,
> > >>'0',  NULL, NULL, NULL, NULL, '1'
> > >>
> > >>
> > >>
> > >> On Thu, Apr 18, 2013 at 9:39 PM, Rohit Yadav <bhaisaab@apache.org>
> > >>wrote:
> > >>
> > >>> On Fri, Apr 19, 2013 at 8:26 AM, Mike Tutkowski <
> > >>> mike.tutkowski@solidfire.com> wrote:
> > >>>
> > >>> > Hi,
> > >>> >
> > >>> > I've switched back to 4.2 (from 4.1), cleaned out my database,
> > >>> re-created
> > >>> > my DevCloud2 environment and all looks good with the exception
> > >>> > that
> > >>>I do
> > >>> > not have a tinyLinux template.
> > >>> >
> > >>> > My SSVM is up and running.
> > >>> >
> > >>> > Any thoughts on what I should do here?
> > >>> >
> > >>>
> > >>> Did you forgot to deploydb with -P tools/devcloud....? Looks like db
> > >>>does  not know about ttylinux; check in cloud.vm_templates etc?
> > >>>
> > >>> Cheers.
> > >>>
> > >>>
> > >>> >
> > >>> > Thanks!
> > >>> >
> > >>> > --
> > >>> > *Mike Tutkowski*
> > >>> > *Senior CloudStack Developer, SolidFire Inc.*
> > >>> > e: mike.tutkowski@solidfire.com
> > >>> > o: 303.746.7302
> > >>> > Advancing the way the world uses the
> > >>> > cloud<http://solidfire.com/solution/overview/?video=play>
> > >>> > * *
> > >>> >
> > >>>
> > >>
> > >>
> > >>
> > >> --
> > >> *Mike Tutkowski*
> > >> *Senior CloudStack Developer, SolidFire Inc.*
> > >> e: mike.tutkowski@solidfire.com
> > >> o: 303.746.7302
> > >> Advancing the way the world uses the
> > >>cloud<http://solidfire.com/solution/overview/?video=play>
> > >> * *
> > >>
> > >
> > >
> > >
> > >--
> > >*Mike Tutkowski*
> > >*Senior CloudStack Developer, SolidFire Inc.*
> > >e: mike.tutkowski@solidfire.com
> > >o: 303.746.7302
> > >Advancing the way the world uses the
> > >cloud<http://solidfire.com/solution/overview/?video=play>
> > >* *
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message