cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Nalley <da...@gnsa.us>
Subject Re: [ACS41] RC Blocker issue. Help Needed!
Date Mon, 22 Apr 2013 20:55:11 GMT
On Mon, Apr 22, 2013 at 4:50 PM, Marcus Sorensen <shadowsor@gmail.com> wrote:
> Why is the HEAD of 4.1 branch now on 4.1.1?  Don't we need a stable 4.1.0
> completed first, before we break 4.1? I ran into several issues today with
> this, and then finally now there's not a database upgrade from 4.1.0 to
> 4.1.1-SNAPSHOT.
>

This is due to the maven release plugin.
It runs two commits - the first to change all of the version numbers
from 4.1.0-SNAPSHOT to 4.1.0
Then a second commit to increment to the next version number 4.1.1-SNAPSHOT.
It of course has no knowledge of pesky database upgrades or version checking.

--David

Mime
View raw message