cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Manikanta Kattamuri <manikanta.kattam...@sungard.com>
Subject Re: failing mvn -P deps in CS 4.0.1
Date Sat, 20 Apr 2013 19:06:50 GMT
Seems like tomcat or some other server is using the default jetty launch
port.
Try stopping tomcat if present and run "mvn -pl :cloud-client-ui jetty:run"


Mani


On Sat, Apr 20, 2013 at 10:23 PM, Ajimangun lintang mas <
ajimangun21@gmail.com> wrote:

> i've passed building CS, but when i want to start management server with
> command "mvn -pl :cloud-client-ui jetty:run" hes occured issue like this :
>
> 2013-04-20 23:16:38.171:WARN::failed SelectChannelConnector@0.0.0.0:8080:
> java.net.BindException: Address already in use
> 2013-04-20 23:16:38.171:WARN::failed Server@5f00fa88:
> java.net.BindException: Address already in use
> [INFO] Jetty server exiting.
> [INFO]
> ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time: 33.183s
> [INFO] Finished at: Sat Apr 20 23:16:38 WIT 2013
> [INFO] Final Memory: 55M/131M
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] Failed to execute goal
> org.mortbay.jetty:maven-jetty-plugin:6.1.26:run (default-cli) on project
> cloud-client-ui: Failure: Address already in use -> [Help 1]
> [ERROR]
> [ERROR] To see the full stack trace of the errors, re-run Maven with the -e
> switch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR]
> [ERROR] For more information about the errors and possible solutions,
> please read the following articles:
> [ERROR] [Help 1]
> http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
> 2013-04-20 23:16:38.560:INFO::Shutdown hook executing
> 2013-04-20 23:16:38.560:INFO::Stopped SelectChannelConnector@0.0.0.0:8080
> 2013-04-20 23:16:39.061:INFO:/client:Closing Spring root
> WebApplicationContext
> 2013-04-20 23:16:39.062:INFO:/client:Shutting down log4j
> 2013-04-20 23:16:39.166:INFO::Shutdown hook complete
>
> there are something incorrect with my configuration?
>
>
>
> 2013/4/19 Ajimangun lintang mas <ajimangun21@gmail.com>
>
> > okay... thanks for your suggestion. i'll try it and post the conclusion
> > later
> >
> >
> >
> > 2013/4/19 Chip Childers <chip.childers@sungard.com>
> >
> >> On Fri, Apr 19, 2013 at 09:47:58PM +0700, Ajimangun lintang mas wrote:
> >> > how about your internet connectivity? with proxy or vpn too or not?
> >>
> >> Sorry, but I never access the internet via proxy or vpn.  You'll have to
> >> look for help on general maven functionality when through a proxy.  This
> >> is definitely something local to you.
> >>
> >> -chip
> >>
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message