cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Tutkowski <mike.tutkow...@solidfire.com>
Subject Re: DevCloud
Date Fri, 19 Apr 2013 01:36:06 GMT
Thanks!  That worked perfectly.

So...I've been doing Java for about a dozen years now, but am new to
Python.  Do we have any documentation that you know of which would have
helped me with this problem?  For example, is this pip solution documented
alongside DevCloud2?  I didn't see any, so was curious if I just missed it.

Thanks again!


On Thu, Apr 18, 2013 at 6:54 PM, Prasanna Santhanam <
Prasanna.Santhanam@citrix.com> wrote:

> pip install requests
>
> That'll fix it.
>
>
> --
> Prasanna.,
>
> ----- Original Message -----
> From: Mike Tutkowski [mailto:mike.tutkowski@solidfire.com]
> Sent: Friday, April 19, 2013 05:57 AM
> To: dev@cloudstack.apache.org <dev@cloudstack.apache.org>
> Subject: Re: DevCloud
>
> I tried
>
> port install py27-requests
>
> (MacPorts), but it didn't change the behavior of running
>
> python ../marvin/marvin/deployDataCenter.py -i devcloud.cfg
>
> Still claims to be unable to find the requests module (for CS 4.2).
>
>
> On Thu, Apr 18, 2013 at 3:45 PM, Mike Tutkowski <
> mike.tutkowski@solidfire.com> wrote:
>
> > Perhaps I'm using the wrong version of Python?  I'm on 2.7.
> >
> >
> > On Thu, Apr 18, 2013 at 11:59 AM, Mike Tutkowski <
> > mike.tutkowski@solidfire.com> wrote:
> >
> >> I have a related issue.  I sent it out under a different thread, but
> >> should put it here, too.
> >>
> >> This is my issue.  I'm not sure how to get around it.  Thanks!!
> >>
> >> mtutkowski-LT:devcloud mtutkowski$ python
> >> ../marvin/marvin/deployDataCenter.py -i devcloud.cfg
> >> Traceback (most recent call last):
> >>   File "../marvin/marvin/deployDataCenter.py", line 21, in <module>
> >>     import cloudstackTestClient
> >>   File
> >>
> "/Users/mtutkowski/Documents/CloudStack/src/incubator-cloudstack/tools/marvin/marvin/cloudstackTestClient.py",
> >> line 18, in <module>
> >>     import cloudstackConnection
> >>   File
> >>
> "/Users/mtutkowski/Documents/CloudStack/src/incubator-cloudstack/tools/marvin/marvin/cloudstackConnection.py",
> >> line 18, in <module>
> >>     import requests
> >> ImportError: No module named requests
> >>
> >>
> >> On Thu, Apr 18, 2013 at 11:51 AM, Rohit Yadav <bhaisaab@apache.org
> >wrote:
> >>
> >>> On Thu, Apr 18, 2013 at 10:17 PM, Aaron Paradowski
> >>> <aaron@paradowski.co.uk>wrote:
> >>>
> >>> > Hi Rohit,****
> >>> >
> >>> > ** **
> >>> >
> >>> > I’m having some problems deploying DevCloud2 and wonder if you could
> >>> help
> >>> > please. So far I have done the following****
> >>> >
> >>> > ** **
> >>> >
> >>> > **1.       **Downloaded and imported the DevCloud2 image into
> >>> VirtualBox
> >>> > – ensured network settings were correct etc.****
> >>> >
> >>> > **2.       **Used PuTTY to SSH to the machine at 192.168.56.10 and
> >>> logged
> >>> > in with root and password for username and password****
> >>> >
> >>> > **3.       **cd to /opt/cloudstack****
> >>> >
> >>> > **4.       **git cloned into the source code for incubator
> >>> cloudstack****
> >>> >
> >>> > **5.       **once that had completed I cd’d to the
> incubator-cloudstack
> >>> > directory****
> >>> >
> >>> > **6.       **Ran mvn clean install –P developer,systemvm****
> >>> >
> >>> > **7.       **Changedthe host value in devcloud.sql to 192.168.56.10
> as
> >>> I
> >>> > want everything to run inside this one VM****
> >>> >
> >>> > **8.       **Ran mvn –pl developer,tools/devloud –Deploydb –P
> developer
> >>> >
> >>>
> >>> Hi Aaron,
> >>>
> >>> The best way is to reach to the whole community and cc any particular
> >>> person whose attention you may be seeking.
> >>>
> >>> 1-8: So far so good, ignoring the -Ddeploydb typo.
> >>>
> >>>
> >>> > ****
> >>> >
> >>> > 9.       Then ran mvn-pl client jetty:run and this is where
> everything
> >>> > goes wrong. It hangs on the below screen for ages then it goes
> through
> >>> lots
> >>> > of warnings and errors such as “WARN [apache.cloudstack.alerts]
> (HA-3:)
> >>> > alertType:: 13” – I left it for 19 hours overnight last night and
> those
> >>> > types of errors just kept going round in cycles?
> >>> >
> >>> Looks like CloudStack issue? Did you try exporting maven opts, checkout
> >>> the
> >>> building on master on cwiki.apache.org / cloudstack and try again?
> >>>
> >>> If you're just able to login inside DevCloud2 and run something like xe
> >>> vm-list and it outputs something we're good at least from DevCloud's
> >>> side :)
> >>>
> >>> Anyone from community?
> >>>
> >>> Cheers.
> >>>
> >>>
> >>> > ****
> >>> >
> >>> > ****
> >>> >
> >>> > ** **
> >>> >
> >>> > Any help would be greatly appreciated! Many thanks in advance.****
> >>> >
> >>> > ** **
> >>> >
> >>> > Kind Regards,****
> >>> >
> >>> > ** **
> >>> >
> >>> > *Aaron Paradowski*
> >>> >
> >>> > ** **
> >>> >
> >>>
> >>
> >>
> >>
> >> --
> >> *Mike Tutkowski*
> >>  *Senior CloudStack Developer, SolidFire Inc.*
> >> e: mike.tutkowski@solidfire.com
> >> o: 303.746.7302
> >> Advancing the way the world uses the cloud<
> http://solidfire.com/solution/overview/?video=play>
> >> *™*
> >>
> >
> >
> >
> > --
> > *Mike Tutkowski*
> > *Senior CloudStack Developer, SolidFire Inc.*
> > e: mike.tutkowski@solidfire.com
> > o: 303.746.7302
> > Advancing the way the world uses the cloud<
> http://solidfire.com/solution/overview/?video=play>
> > *™*
> >
>
>
>
> --
> *Mike Tutkowski*
> *Senior CloudStack Developer, SolidFire Inc.*
> e: mike.tutkowski@solidfire.com
> o: 303.746.7302
> Advancing the way the world uses the
> cloud<http://solidfire.com/solution/overview/?video=play>
> *™*
>



-- 
*Mike Tutkowski*
*Senior CloudStack Developer, SolidFire Inc.*
e: mike.tutkowski@solidfire.com
o: 303.746.7302
Advancing the way the world uses the
cloud<http://solidfire.com/solution/overview/?video=play>
*™*

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message