cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Will Stevens <wstev...@cloudops.com>
Subject Re: Error running Ddeploysvr
Date Tue, 23 Apr 2013 20:04:15 GMT
Chip:  Yes, the problem was the MAVEN_OPS, I had to run this before I ran
that command.

$ export MAVEN_OPTS=""

I tried to re-run the command that Prasanna sent (as root) after running
that and I got the following:

[DEBUG] Executing command line: python setup.py sdist
running sdist
running egg_info
writing requirements to Marvin.egg-info/requires.txt
writing Marvin.egg-info/PKG-INFO
writing top-level names to Marvin.egg-info/top_level.txt
writing dependency_links to Marvin.egg-info/dependency_links.txt
writing entry points to Marvin.egg-info/entry_points.txt
reading manifest file 'Marvin.egg-info/SOURCES.txt'
reading manifest template 'MANIFEST.in'
warning: no files found matching '*.txt' under directory 'docs'
writing manifest file 'Marvin.egg-info/SOURCES.txt'
warning: sdist: standard file not found: should have one of README,
README.txt

making hard links in Marvin-0.1.0...
hard linking CHANGES.txt -> Marvin-0.1.0
error: Operation not permitted
[INFO]
------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO]
------------------------------------------------------------------------
[INFO] Total time: 9.782s
[INFO] Finished at: Tue Apr 23 15:31:45 EDT 2013
[INFO] Final Memory: 19M/45M
[INFO]
------------------------------------------------------------------------


HOWEVER, after this I just tried to run the original command I was using
before:
$ mvn -P developer -pl tools/devcloud -Ddeploysvr -X

This time everything deployed successfully, so I am not entirely sure what
was going on, but my dev environment is back up and running.  Thank you
both for your help on this.

Cheers,

Will




On Tue, Apr 23, 2013 at 2:10 PM, Chip Childers <chip.childers@sungard.com>wrote:

> On Tue, Apr 23, 2013 at 02:05:03PM -0400, Will Stevens wrote:
> > I have changed my 'python' reference to point to my 2.7 version (which
> > seems to be working).
> >
> > When I start the server and then run this in another terminal window I
> get
> > this:
> >
> > [root@cs4-devcloud incubator-cloudstack]# mvn -Pdeveloper,marvin.sync
> > -Dendpoint=localhost -pl :cloud-marvin
> > ERROR: transport error 202: bind failed: Address already in use
> > ERROR: JDWP Transport dt_socket failed to initialize, TRANSPORT_INIT(510)
> > JDWP exit error AGENT_ERROR_TRANSPORT_INIT(197): No transports
> initialized
> > [../../../src/share/back/debugInit.c:690]
> > FATAL ERROR in native method: JDWP No transports initialized,
> > jvmtiError=AGENT_ERROR_TRANSPORT_INIT(197)
> > Aborted
> >
> > I have also tried using the actual IP of my server instead of localhost
> > (but it gives the same error).  I will need to figure out what is
> blocking
> > it here.
> >
> > Thanks again...
>
> You probably have MAVEN_OPTS configured to open a port for debuggers to
> attach to.  This is normally not a problem, but it means that two mvn
> processes can't open the same port.  Either export a new MAVEN_OPTS just
> prior to running the second shell's commands OR disable debugging in
> maven completely.
>
> I hit this before as well...
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message