cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nguyen Anh Tu <ng.t...@gmail.com>
Subject Using new systemvm template from Jenkin but failed
Date Wed, 24 Apr 2013 09:11:03 GMT
Hi guys,

I downloaded latest systemvm template (32bit) from
http://jenkins.cloudstack.org and registered successfully to CloudStack.
But when SSVM & CPVM started, it failed. Log is here:

2013-04-24 14:38:12,496 DEBUG [xen.resource.CitrixResourceBase]
(DirectAgent-8:null) 1. The VM v-6-VM is in Starting state.
2013-04-24 14:38:12,540 ERROR [mom.rabbitmq.RabbitMQEventBus]
(secstorage-1:null) Failed to create a connection to AMQP server due to
Connection refused
2013-04-24 14:38:12,540 WARN  [storage.listener.VolumeStateListener]
(secstorage-1:null) Failed to state change event on the the event bus.
2013-04-24 14:38:12,549 DEBUG [xen.resource.CitrixResourceBase]
(DirectAgent-8:null) Created VM 1efc01b8-d56e-d5a5-0318-22c6d27de7c1 for
v-6-VM
2013-04-24 14:38:12,556 DEBUG
[storage.secondary.SecondaryStorageManagerImpl] (secstorage-1:null) Boot
Args for VM[SecondaryStorageVm|s-5-VM]:  template=domP type=secstorage
host=192.168.4.246 por$
2013-04-24 14:38:12,604 DEBUG [xen.resource.CitrixResourceBase]
(DirectAgent-8:null) PV args are -- quiet
console=hvc0%template=domP%type=consoleproxy%host=192.168.4.246%port=8250%name=v-6-VM%prem$
2013-04-24 14:38:12,630 DEBUG [agent.transport.Request] (secstorage-1:null)
Seq 1-437911564: Waiting for Seq 437911563 Scheduling:  { Cmd , MgmtId:
158515241344302, via: 1, Ver: v1, Flags: 100111,$
2013-04-24 14:38:12,634 DEBUG [xen.resource.CitrixResourceBase]
(DirectAgent-8:null) VBD b71e2d0c-cb34-5efb-554c-0c370be25df4 created for
Vol[6|ROOT|41f8f2ba-5955-4170-8611-830e90cba0a6|2097152]
2013-04-24 14:38:12,798 DEBUG [xen.resource.CitrixResourceBase]
(DirectAgent-8:null) Creating VIF for v-6-VM on nic
[Nic:Public-192.168.4.152-vlan://untagged]
2013-04-24 14:38:12,831 DEBUG [xen.resource.CitrixResourceBase]
(DirectAgent-8:null) Created a vif 0fa8350a-169c-cfdc-e239-0630db9bb797 on 2
2013-04-24 14:38:12,831 DEBUG [xen.resource.CitrixResourceBase]
(DirectAgent-8:null) Creating VIF for v-6-VM on nic
[Nic:Control-169.254.1.32-null]
2013-04-24 14:38:12,882 DEBUG [xen.resource.CitrixResourceBase]
(DirectAgent-8:null) already have a vif on dom0 for link local network
2013-04-24 14:38:12,995 DEBUG [xen.resource.CitrixResourceBase]
(DirectAgent-8:null) Created a vif 0d6e562c-f9a6-aaee-b52a-c3ab08e70d36 on 0
2013-04-24 14:38:12,995 DEBUG [xen.resource.CitrixResourceBase]
(DirectAgent-8:null) Creating VIF for v-6-VM on nic
[Nic:Management-192.168.4.168-null]
2013-04-24 14:38:13,022 DEBUG [xen.resource.CitrixResourceBase]
(DirectAgent-8:null) Created a vif 5bc21c8c-46ed-cea7-23cc-fb9067eb7f2e on 1
2013-04-24 14:38:15,688 DEBUG [agent.manager.DirectAgentAttache]
(DirectAgent-1:null) Ping from 1
2013-04-24 14:38:16,067 DEBUG [agent.manager.DirectAgentAttache]
(DirectAgent-5:null) Seq 1-437911556: Executing request
2013-04-24 14:38:16,068 WARN  [xen.resource.CitrixResourceBase]
(DirectAgent-8:null) Task failed! Task record:                 uuid:
d1a3f55d-64e6-9e4d-449b-3baa683f31af
           nameLabel: Async.VM.start_on
     nameDescription:
   allowedOperations: []
   currentOperations: {}
             created: Wed Apr 24 14:32:45 ICT 2013
            finished: Wed Apr 24 14:32:47 ICT 2013
              status: failure
          residentOn: com.xensource.xenapi.Host@f488f094
            progress: 1.0
                type: <none/>
              result:
           errorInfo: [WARNING: /dev/xvda is not a disk image, Traceback
(most recent call last):,   File "/usr/bin/pygrub", line 746, in ?,
raise RuntimeError, "Unable to find partition conta$
         otherConfig: {}
           subtaskOf: com.xensource.xenapi.Task@aaf13f6f
            subtasks: []
        at
com.cloud.hypervisor.xen.resource.CitrixResourceBase.checkForSuccess(CitrixResourceBase.java:3395)
        at
com.cloud.hypervisor.xen.resource.CitrixResourceBase.startVM(CitrixResourceBase.java:3507)
        at
com.cloud.hypervisor.xen.resource.CitrixResourceBase.execute(CitrixResourceBase.java:1473)
        at
com.cloud.hypervisor.xen.resource.CitrixResourceBase.executeRequest(CitrixResourceBase.java:440)
        at
com.cloud.hypervisor.xen.resource.XcpServerResource.executeRequest(XcpServerResource.java:52)
        at
com.cloud.agent.manager.DirectAgentAttache$Task.run(DirectAgentAttache.java:186)
        at
java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
        at
java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
        at java.util.concurrent.FutureTask.run(FutureTask.java:166)
        at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:178)
        at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:292)
        at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
        at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
        at java.lang.Thread.run(Thread.java:722)


How can I fix it? Appreciate for any help :-)
-- 

N.g.U.y.e.N.A.n.H.t.U

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message