cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hugo Trippaers <HTrippa...@schubergphilis.com>
Subject RE: Master broken
Date Wed, 03 Apr 2013 07:42:37 GMT
Kelven,

That commit (5782abf8f80fce929e3d6e20068bc165f2360426 ) was actually the commit that broke
the tests. In that commit you add the call to 'ComponentContext.initComponentsLifeCycle();'
which in turn initializes other modules and some of them make database calls. Those database
call will fail on our Jenkins systems as they have no database running.

Can you try the following:
 * shutdown any local mysql databases
 * git checkout 5782abf8f80fce929e3d6e20068bc165f2360426
 * mvn clean test

I expect that you will get the same error, if not something strange is happening. You have
to make sure that you are not running a database on the localhost though. Otherwise the test
will succeed.

I'll add a negative testcase that will fail if a local database is present to prevent this,
I ran into the same problem a while back.

Cheers,

Hugo




> -----Original Message-----
> From: Kelven Yang [mailto:kelven.yang@citrix.com]
> Sent: Tuesday, April 02, 2013 7:41 PM
> To: Alena Prokharchyk; dev@cloudstack.apache.org; cloudstack-
> dev@incubator.apache.org; Hugo Trippaers
> Subject: Re: Master broken
> 
> I've applied a commit 5782abf8f80fce929e3d6e20068bc165f2360426 to
> address these test configuration fix already. This was done at last Friday.
> 
> Kelven
> 
> 
> 
> On 4/2/13 9:39 AM, "Alena Prokharchyk" <Alena.Prokharchyk@citrix.com>
> wrote:
> 
> >The test itself is written by me. It doesn't touch the DB - I mock
> >"persist" method of the corresponding Dao. The test was added about 2
> >weeks ago to master branch, and it was running fine the last time I've
> >checked - last Friday.
> >
> >As Pranav stated, the test got broken with commit
> >5782abf8f80fce929e3d6e20068bc165f2360426, and related to UserContext
> >initializing.
> >
> >-Alena.
> >
> >On 4/2/13 1:32 AM, "Pranav Saxena" <pranav.saxena@citrix.com> wrote:
> >
> >>Yeah I saw that . Thanks Hugo . I hope master is stable now though I
> >>haven't got a change to build it again.
> >>
> >>Regards,
> >>Pranav
> >>
> >>-----Original Message-----
> >>From: Hugo Trippaers [mailto:HTrippaers@schubergphilis.com]
> >>Sent: Tuesday, April 02, 2013 1:37 PM
> >>To: dev@cloudstack.apache.org; cloudstack-dev@incubator.apache.org
> >>Subject: RE: Master broken
> >>
> >>Thanks Pranav,
> >>
> >>I couldn't find an easy way to fix the test so I indeed disabled it.
> >>See commit df6b97c194caa8b34fa14bf5164eb2fe1f26b2b1.
> >>
> >>Raised a ticket for Kelven (CLOUDSTACK-1884) to have a look at it.
> >>
> >>Cheers,
> >>
> >>Hugo
> >>
> >>> -----Original Message-----
> >>> From: Pranav Saxena [mailto:pranav.saxena@citrix.com]
> >>> Sent: dinsdag 2 april 2013 10:04
> >>> To: dev@cloudstack.apache.org; cloudstack-dev@incubator.apache.org
> >>> Subject: RE: Master broken
> >>>
> >>> This commit deals with the tests for create network offering - Commit:
> >>> 5782abf8f80fce929e3d6e20068bc165f2360426 and I am presuming
> because
> >>> of this only the test is failing.
> >>>
> >>> You might need to revert the commit if required.
> >>>
> >>> Thanks,
> >>> Pranav
> >>>
> >>> -----Original Message-----
> >>> From: Hugo Trippaers [mailto:HTrippaers@schubergphilis.com]
> >>> Sent: Tuesday, April 02, 2013 12:32 PM
> >>> To: cloudstack-dev@incubator.apache.org
> >>> Subject: Master broken
> >>>
> >>> Heya all,
> >>>
> >>> Master branch appears to be broken. Is anybody working on this?
> >>>
> >>> The failed tests are:
> >>> >>>
> >>>
> >>>org.apache.cloudstack.networkoffering.CreateNetworkOfferingTest.c
> >>> >>>re
> >>> ateSharedNtwkOffWithNoVlan
> >>> >>>
> >>>
> >>>org.apache.cloudstack.networkoffering.CreateNetworkOfferingTest.c
> >>> >>>re
> >>> ateSharedNtwkOffWithoutSpecifyIpRanges
> >>> >>>
> >>>
> >>>org.apache.cloudstack.networkoffering.CreateNetworkOfferingTest.c
> >>> >>>re
> >>> ateIsolatedNtwkOffWithSpecifyIpRangesAndSourceNat
> >>> >>>
> >>>
> >>>org.apache.cloudstack.networkoffering.CreateNetworkOfferingTest.c
> >>> >>>re
> >>> ateSharedNtwkOffWithVlan
> >>> >>>
> >>>
> >>>org.apache.cloudstack.networkoffering.CreateNetworkOfferingTest.c
> >>> >>>re
> >>> ateSharedNtwkOffWithSpecifyIpRanges
> >>> >>>
> >>>
> >>>org.apache.cloudstack.networkoffering.CreateNetworkOfferingTest.c
> >>> >>>re
> >>> ateIsolatedNtwkOffWithNoVlan
> >>> >>>
> >>>
> >>>org.apache.cloudstack.networkoffering.CreateNetworkOfferingTest.c
> >>> >>>re
> >>> ateIsolatedNtwkOffWithVlan
> >>> >>>
> >>>
> >>>org.apache.cloudstack.networkoffering.CreateNetworkOfferingTest.c
> >>> >>>re
> >>> ateIsolatedNtwkOffWithSpecifyIpRangesAndNoSourceNat
> >>>
> >>>
> >>> It appears to have something to do with the
> >>> CreateNetworkOfferingTest trying to use the database (which is never
> >>> there during test runs)
> >>>
> >>> I'm looking at it, but if somebody else is doing that as well we
> >>> might pool resources.
> >>>
> >>> Cheers,
> >>>
> >>> Hugo
> >>
> >>
> >
> >


Mime
View raw message