cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chip Childers <chip.child...@sungard.com>
Subject Re: failing mvn -P deps in CS 4.0.1
Date Fri, 19 Apr 2013 13:27:05 GMT
On Apr 19, 2013, at 8:01 AM, Ajimangun lintang mas
<ajimangun21@gmail.com> wrote:

> yes, my pc connected to vpn for internet connectivity. this problem comes
> from maven/pom configuration or about internet connectivity?

I can tell you that I'm not having any issues.

>
> 2013/4/18 Chip Childers <chip.childers@sungard.com>
>
>> On Thu, Apr 18, 2013 at 04:11:42PM +0700, Ajimangun lintang mas wrote:
>>> # mvn -P deps
>>> [INFO] Scanning for projects...
>>> Downloading:
>>> http://repo.maven.apache.org/maven2/org/apache/apache/11/apache-11.pom
>>> [ERROR] The build could not read 1 project -> [Help 1]
>>> [ERROR]
>>> [ERROR]   The project
>>> org.apache.cloudstack:cloudstack:4.0.1-incubating-SNAPSHOT
>>> (/usr/local/apache-cloudstack-4.0.1-incubating-src/pom.xml) has 1 error
>>> [ERROR]     Non-resolvable parent POM: Could not transfer artifact
>>> org.apache:apache:pom:11 from/to central (
>>> http://repo.maven.apache.org/maven2): repo.maven.apache.org and
>>> 'parent.relativePath' points at wrong local POM @ line 23, column 11:
>>> Unknown host repo.maven.apache.org -> [Help 2]
>>> [ERROR]
>>> [ERROR] To see the full stack trace of the errors, re-run Maven with the
>> -e
>>> switch.
>>> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
>>> [ERROR]
>>> [ERROR] For more information about the errors and possible solutions,
>>> please read the following articles:
>>> [ERROR] [Help 1]
>> http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
>>> [ERROR] [Help 2]
>> http://cwiki.apache.org/confluence/display/MAVEN/UnresolvableModelException
>>>
>>> i've installed mysqld,maven,tomcat,java but when i want to pull
>>> denpendencies for CS with "mvn -P deps" command, occuring proccess like
>>> that. anybody can help?
>>> thanks
>>
>> That sounds like a connectivity issue in getting to the
>> repo.maven.apache.org site.  Are you doing this with a working
>> connection to the Internet?  Perhaps the site was done temporarily?
>>

Mime
View raw message