cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Musayev, Ilya" <imusa...@webmd.net>
Subject RE: VMware blocker - Any takers to fix it? (Was: [jira] [Assigned] (CLOUDSTACK-1252) Failed to download default template in VMware)
Date Tue, 05 Mar 2013 19:06:34 GMT
I'll pick this up..

> -----Original Message-----
> From: Chip Childers [mailto:chip.childers@sungard.com]
> Sent: Friday, March 01, 2013 9:47 AM
> To: cloudstack-dev@incubator.apache.org
> Subject: VMware blocker - Any takers to fix it? (Was: [jira] [Assigned]
> (CLOUDSTACK-1252) Failed to download default template in VMware)
> 
> Anybody willing to take this bug?
> 
> On Fri, Mar 01, 2013 at 02:33:13PM +0000, Rohit Yadav (JIRA) wrote:
> >
> >      [
> > https://issues.apache.org/jira/browse/CLOUDSTACK-
> 1252?page=com.atlassi
> > an.jira.plugin.system.issuetabpanels:all-tabpanel ]
> >
> > Rohit Yadav reassigned CLOUDSTACK-1252:
> > ---------------------------------------
> >
> >     Assignee:     (was: Rohit Yadav)
> >
> > Unassigning to be picked up somebody that has VMWare setup to test
> against, have neither time nor a vmware this weekend.
> >
> > > Failed to download default template in VMware
> > > ---------------------------------------------
> > >
> > >                 Key: CLOUDSTACK-1252
> > >                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-1252
> > >             Project: CloudStack
> > >          Issue Type: Bug
> > >      Security Level: Public(Anyone can view this level - this is the default.)
> > >          Components: KVM, VMware
> > >    Affects Versions: 4.1.0
> > >         Environment: CentOS6.3
> > > 4.1 branch build
> > > Hyper visor : VMware
> > >            Reporter: Rayees Namathponnan
> > >            Priority: Blocker
> > >             Fix For: 4.1.0
> > >
> > >         Attachments: cloud.rar
> > >
> > >
> > > Step 1 : Created new build from 4.1 branch Step 2 : Install and
> > > configured MS server on CentOS 6.3 Step 3 : Prepared system template
> > > and created advanced zone Actual result System VM are created, but
> > > "default templates" are not available in template section.
> > >
> > > I tried to started agent from SSVM, with command ">service
> > > cloudstack-agent start" and failed,  but command ">service cloud
> > > start" works If you look at the SSVM cloud.out
> > > (/var/log/cloud/clout.out) you can see class not found exception
> > > java.lang.ClassNotFoundException:
> > > com.cloud.storage.resource.PremiumSecondaryStorageResource
> > > + java -Djavax.net.ssl.trustStore=./certs/realhostip.keystore
> > > + -mx168m -cp
> > > + ./:./conf:aopalliance-1.0.jar:apache-log4j-extras-1.1.jar:aspectjr
> > > + t-1.7.1.jar:aspectjweaver-1.7.1.jar:aws-java-sdk-1.3.21.1.jar:back
> > > + port-util-concurrent-3.1.jar:bcprov-jdk16-1.46.jar:cglib-nodep-2.2
> > > + .2.jar:cloud-agent-4.1.0-SNAPSHOT.jar:cloud-api-4.1.0-SNAPSHOT.jar
> > > + :cloud-console-proxy-4.1.0-SNAPSHOT.jar:cloud-core-4.1.0-SNAPSHOT.
> > > + jar:cloud-utils-4.1.0-SNAPSHOT.jar:commons-codec-1.6.jar:commons-c
> > > + ollections-3.2.1.jar:commons-configuration-1.8.jar:commons-dbcp-1.
> > > + 4.jar:commons-discovery-0.5.jar:commons-httpclient-3.1.jar:commons
> > > + -lang-2.6.jar:commons-logging-1.1.1.jar:commons-pool-1.6.jar:dom4j
> > > + -1.6.1.jar:ehcache-1.5.0.jar:ejb-api-3.0.jar:gson-1.7.1.jar:guava-
> > > + 14.0-rc1.jar:httpclient-4.1.jar:httpcore-4.1.jar:jackson-core-asl-
> > > + 1.8.9.jar:jackson-mapper-asl-1.8.9.jar:jasypt-1.9.0.jar:java-ipv6-
> > > + 0.8.jar:javassist-3.12.1.GA.jar:javax.inject-1.jar:javax.persisten
> > > + ce-2.0.0.jar:jsch-0.1.42.jar:jsr107cache-1.0.jar:log4j-1.2.16.jar:
> > > + reflections-0.9.8.jar:spring-aop-3.1.2.RELEASE.jar:spring-asm-3.1.
> > > + 2.RELEASE.jar:spring-beans-3.1.2.RELEASE.jar:spring-context-3.1.2.
> > > + RELEASE.jar:spring-core-3.1.2.RELEASE.jar:spring-expression-3.1.2.
> > > + RELEASE.jar:spring-web-3.1.2.RELEASE.jar:trilead-ssh2-build213-svn
> > > + kit-1.3-patch.jar:xml-apis-1.0.b2.jar com.cloud.agent.AgentShell
> > > + template=domP type=secstorage host=10.223.49.197 port=8250
> > > + name=s-3-VM zone=1 pod=1 guid=s-3-VM
> > > +
> resource=com.cloud.storage.resource.PremiumSecondaryStorageResourc
> > > + e instance=SecStorage sslcopy=true role=templateProcessor mtu=1500
> > > + eth2ip=10.223.243.20 eth2mask=255.255.255.192 gateway=10.223.243.1
> > > + public.network.device=eth2 eth0mask=0.0.0.0 eth0ip=0.0.0.0
> > > + eth1ip=10.223.250.169 eth1mask=255.255.255.192
> > > + mgmtcidr=10.223.49.192/26 localgw=10.223.250.129
> > > + private.network.device=eth1 eth3ip=10.223.250.156
> > > + eth3mask=255.255.255.192 storageip=10.223.250.156
> > > + storagenetmask=255.255.255.192 storagegateway=10.223.250.129
> > > + internaldns1=10.223.110.254 internaldns2=10.223.110.253
> > > + dns1=72.52.126.11 dns2=72.52.126.12
> > > log4j:WARN No appenders could be found for logger
> (org.apache.commons.httpclient.params.DefaultHttpParams).
> > > log4j:WARN Please initialize the log4j system properly.
> > > log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig
> for more info.
> > > Unable to start agent: Resource class not found:
> > > com.cloud.storage.resource.PremiumSecondaryStorageResource due to:
> > > java.lang.ClassNotFoundException:
> > > com.cloud.storage.resource.PremiumSecondaryStorageResource
> > > Attached cloud.out for reference
> >
> > --
> > This message is automatically generated by JIRA.
> > If you think it was sent incorrectly, please contact your JIRA
> > administrators For more information on JIRA, see:
> > http://www.atlassian.com/software/jira
> >



Mime
View raw message