cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Abhinandan Prateek <Abhinandan.Prat...@citrix.com>
Subject Re: Unable to create a deployment for VM
Date Thu, 28 Mar 2013 07:44:37 GMT
It seems you have a cluster of management servers. It is possible that the
host/agents are owned by the the management server that is inactive:

2013-03-28 02:07:22,340 INFO  [cloud.cluster.ClusterManagerImpl]
(Cluster-Heartbeat-1:null) Management node 1 is *detected inactive* by
timestamp but is pingable


-abhi


On 28/03/13 12:41 PM, "Maurice Lawler" <maurice.lawler@me.com> wrote:

>Attempting to create a VM from a template I created (Twice) getting this
>in my logs: 
>
>013-03-28 02:07:17,873 WARN  [cloud.api.ApiDispatcher]
>(Job-Executor-22:job-77) class com.cloud.api.ServerApiException : Unable
>to create a deployment for VM[User|i-2-11-VM]
>2013-03-28 02:07:17,873 DEBUG [cloud.async.AsyncJobManagerImpl]
>(Job-Executor-22:job-77) Complete async job-77, jobStatus: 2, resultCode:
>530, result: com.cloud.api.response.ExceptionResponse@2637df06
>2013-03-28 02:07:19,339 DEBUG [cloud.cluster.ClusterManagerImpl]
>(Cluster-Heartbeat-1:null) Detected management node left, id:1,
>nodeIP:0.0.0.0
>2013-03-28 02:07:19,339 INFO  [cloud.cluster.ClusterManagerImpl]
>(Cluster-Heartbeat-1:null) Trying to connect to 0.0.0.0
>2013-03-28 02:07:19,340 INFO  [cloud.cluster.ClusterManagerImpl]
>(Cluster-Heartbeat-1:null) Management node 1 is detected inactive by
>timestamp but is pingable
>2013-03-28 02:07:20,839 DEBUG [cloud.cluster.ClusterManagerImpl]
>(Cluster-Heartbeat-1:null) Detected management node left, id:1,
>nodeIP:0.0.0.0
>2013-03-28 02:07:20,840 INFO  [cloud.cluster.ClusterManagerImpl]
>(Cluster-Heartbeat-1:null) Trying to connect to 0.0.0.0
>2013-03-28 02:07:20,840 INFO  [cloud.cluster.ClusterManagerImpl]
>(Cluster-Heartbeat-1:null) Management node 1 is detected inactive by
>timestamp but is pingable
>2013-03-28 02:07:21,183 DEBUG [cloud.server.StatsCollector]
>(StatsCollector-2:null) VmStatsCollector is running...
>2013-03-28 02:07:21,219 DEBUG [cloud.vm.VirtualMachineManagerImpl]
>(AgentManager-Handler-9:null) Cleanup succeeded. Details null
>2013-03-28 02:07:21,219 DEBUG [agent.transport.Request]
>(StatsCollector-2:null) Seq 1-2359860: Received:  { Ans: , MgmtId:
>279278805451068, via: 1, Ver: v1, Flags: 10, { GetVmStatsAnswer } }
>2013-03-28 02:07:21,219 DEBUG [cloud.vm.VirtualMachineManagerImpl]
>(StatsCollector-2:null) Cleanup succeeded. Details null
>2013-03-28 02:07:22,339 DEBUG [cloud.cluster.ClusterManagerImpl]
>(Cluster-Heartbeat-1:null) Detected management node left, id:1,
>nodeIP:0.0.0.0
>2013-03-28 02:07:22,340 INFO  [cloud.cluster.ClusterManagerImpl]
>(Cluster-Heartbeat-1:null) Trying to connect to 0.0.0.0
>2013-03-28 02:07:22,340 INFO  [cloud.cluster.ClusterManagerImpl]
>(Cluster-Heartbeat-1:null) Management node 1 is detected inactive by
>timestamp but is pingable
>2013-03-28 02:07:22,629 DEBUG [cloud.async.AsyncJobManagerImpl]
>(catalina-exec-1:null) Async job-77 completed
>2013-03-28 02:07:23,586 DEBUG
>[storage.secondary.SecondaryStorageManagerImpl] (secstorage-1:null) Zone
>1 is ready to launch secondary storage VM
>2013-03-28 02:07:23,710 DEBUG
>[cloud.consoleproxy.ConsoleProxyManagerImpl] (consoleproxy-1:null) Zone 1
>is ready to launch console proxy
>2013-03-28 02:07:23,839 DEBUG [cloud.cluster.ClusterManagerImpl]
>(Cluster-Heartbeat-1:null) Detected management node left, id:1,
>nodeIP:0.0.0.0
>2013-03-28 02:07:23,839 INFO  [cloud.cluster.ClusterManagerImpl]
>(Cluster-Heartbeat-1:null) Trying to connect to 0.0.0.0
>
>
>
>Lots of: 2013-03-28 02:07:19,339 INFO  [cloud.cluster.ClusterManagerImpl]
>(Cluster-Heartbeat-1:null) Trying to connect to 0.0.0.0 (of course it's
>no really 0.0.0.0) but yeah, not sure how to solve this.
>
>Any thoughts? 


Mime
View raw message