cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcus Sorensen <shadow...@gmail.com>
Subject Re: Using newer DIY SystemVMs
Date Wed, 06 Mar 2013 01:04:49 GMT
Rohit, I think I tracked down why the router keeps rebooting. When it
comes up, the first thing we do is run get_template_version.sh, which
replies:

/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
Cloudstack Release 4.2.0 Tue Mar 5 13:17:51 UTC
2013&a8af8cdd546e575e64f69b6f80ef949c

Looks like we don't like that locale warning:

GetDomRVersionAnswer":{"result":false,"details":"bash: warning:
setlocale: LC_ALL: cannot change locale (en_US.UTF-8)"

I can fix it by running this in the system vm:

locale-gen en_US.UTF-8

On Tue, Mar 5, 2013 at 10:43 AM, Chiradeep Vittal
<Chiradeep.Vittal@citrix.com> wrote:
> OK, one more niggle about the previous system vm. We tried to enable aesni
> [1] to boost encryption performance (ipsec vpn, anything ssl), but the
> system vm would crash on Vmware if we did that (hence the module
> blacklisted). Could someone try the new systemvm on VMWare with aesni
> enabled? I believe it is as simple as
> modprobe aesni_intel and
> openssl 1.0.1
>
> [1] http://en.wikipedia.org/wiki/AES_instruction_set
>
> On 3/4/13 10:46 PM, "Rohit Yadav" <bhaisaab@apache.org> wrote:
>
>>Hi all,
>>
>>Thanks to Mate
>>(blogs.citrix.com/2012/10/04/convert-a-raw-image-to-xenserver-vhd/)
>>I'm able to ship appliances that work for Xen. Chiradeep, there is no
>>need to use the powershell hack now, if people still want vhdx, they
>>can use that hack. The current appliance for Xen (vbox->raw->vhd)
>>works.
>>
>>At least appliance for HyperV and Xen works:
>>http://jenkins.cloudstack.org/job/build-systemvm-master/
>>
>>I've tested and found that:
>>- patching happens
>>- password server works
>>- apache was running, user data works
>>- template creation works
>>- snapshot to template works
>>
>>I won't be able to test VPC/advance zone of DevCloud, ipv6 etc.
>>someone from QA would have to help.
>>Thanks Marcus for your suggestion, will compress qcow2 and test on KVM
>>today.
>>I need help on testing/fixing VMWare systemvm template appliance.
>>
>>Ahmad :) all natural:
>>http://highlatencylife.files.wordpress.com/2010/12/awesomesauce.png
>>
>>Regards.
>>PS. Was AFK yesterday, down with flu, much better now.
>>
>>On Fri, Mar 1, 2013 at 11:29 PM, Chiradeep Vittal
>><Chiradeep.Vittal@citrix.com> wrote:
>>>
>>>
>>> On 3/1/13 4:03 AM, "Rohit Yadav" <bhaisaab@apache.org> wrote:
>>>>
>>>>- Saw systemvms started from the template, saw patching happening,
>>>>logged in with creds (root/password) to verify that it was indeed the
>>>>new one (Linux 3.2 :)
>>>>- The agents were running fine, there was a latency issue (agents were
>>>>lagging behind)
>>>>- (Applied a fix describe on CLOUDSTACK-1370 to make the deployVM
>>>>work) VR came up, did it's SDN magic and tinyLinux was deployed
>>>>- Console proxy worked for me as well
>>>
>>> I would also test
>>>  - password server
>>>  - user data management (is apache web server running?)
>>> In addition
>>>  - zone-to-zone template copy
>>>  - template creation
>>>  - convert snapshot to template
>>>  - vpc
>>>  - ipv6
>>>
>>>>
>>>>Chiradeep, is there a way to convert VHD (HyperV) to VHD (Xen), I hear
>>>>that they both differ in some magic bits?
>>> Actually since we intend to support Windows 2012, we should be using
>>>VHDX.
>>> There's a way to do it with Powershell (from vhd(hyper-v) -> vhdx)
>>>
>>>http://blogs.msdn.com/b/virtual_pc_guy/archive/2012/10/03/using-powershel
>>>l-
>>> to-convert-a-vhd-to-a-vhdx.aspx
>>>
>>>
>

Mime
View raw message