cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sudha Ponnaganti <>
Subject RE: [ACS41][QA] Has anyone upgraded from 4.0 to 4.1
Date Wed, 27 Mar 2013 21:37:59 GMT
No - not done on ubuntu as upgrade hasn't worked at all so far even on CentOS
We will test it if CentOS works. These are the two upgrades that are being tested [1]


-----Original Message-----
From: Marcus Sorensen [] 
Sent: Wednesday, March 27, 2013 2:27 PM
Subject: Re: [ACS41][QA] Has anyone upgraded from 4.0 to 4.1

It should be fixed. This should be less difficult in the future, as long as we're not moving
the config directories around again. I first tried copying the files over during the upgrade
prior to the old RPMs being removed, but RPM's config(noreplace) only seems to work on files
that it knew were in the previous RPM being upgraded. So I settled on moving the /etc/cloud
directory to /etc/cloud.rpmsave, and then cherry picking the,,
and db key files into the new config directory. Then I looked at the tomcat6.conf and server.xml
links and recreated new ones in /etc/cloudstack/management based on whether the old ones were
ssl or non-ssl. The files themselves had changed between versions, so I did this rather than
copying anything.

Now the big question, has anyone tested upgrades on Ubuntu 12.04? Or do we plan to?

On Wed, Mar 27, 2013 at 11:11 AM, Pradeep Soundararajan <>
> These are my observations I have captured during my testing:
> 1)      'service cloudstack-management start' is failing for the first time since it
did not find tomcat6.conf and server.xml. This will get created (symb links) only if you execute
"cloudstack-setup-management" for the first time after the upgrade since this will be treated
as a fresh install because rpm names and locations have been changed from 4.1.  I have found
the symb links are getting updated during the upgrade only if the upgrade path is present
already. In our situation upgrade path is pretty new.
> 2)      I have observed of 4.1 is different from 4.0.  I have observed
there is an issue with initially, that is the reason I have tried to redploy
DB and launched 4.1 MS. But realized and got to know from QA that we should not redploy db
after the upgrade.  Let me know how to handle the situation if are changed in
> I was trying to keep a check in cloud.spec incase cloud-client is present in the system
or not. Then I was trying to provide the symb link of the files which are needed for the upgrade
like, tomcat6.conf etc from the old path /etc/cloud/management to the new path
> I have tried these below in cloud.spec but went in vain:
> %define _rpm_check_ver %(`rpm -q cloud-client-4.0.0 > /dev/null`) %if 
> "%{?_rpm_check_ver}" != "0"
> Obsoletes: cloud-client < 4.1.0
> %endif
> I hope Marcus is looking at this now.  Let's wait for his feedback.
> Thanks,
> Pradeep S
> -----Original Message-----
> From: Sudha Ponnaganti []
> Sent: Tuesday, March 26, 2013 2:45 AM
> To:
> Subject: [ACS41][QA] Has anyone upgraded from 4.0 to 4.1
> Hi,
> Requesting help to resolve the following issue, if you have done upgrade.
> Upgrade is failing - if there is anyone that can take a look at it during US time zone
that would be great.
> Thanks
> /Sudha

View raw message