cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Francois Gaudreault <fgaudrea...@cloudops.com>
Subject Re: Couple VMWare Issues with 4.1
Date Thu, 28 Mar 2013 17:25:24 GMT

>> 2 - Public VLAN created on vSwitch0 even if we tell to use vSwitch2.
>>
>> For some reason, CS creates a tagged port-group on the vSwitch0 for the
>> public interface of the VR even if we told CS to use vSwitch2. In fact, CS
>> creates and uses the public port-group on the vSwitch2... So why it creates
>> an unused port-group on vSwitch0? See attached screenshot.
>>
>> Preparing NIC device on network cloud.public.142.0.1-vSwitch0 INFO
>> [vmware.resource.VmwareResource] (DirectAgent-47:yul01vi13.ops.dot)
>> Prepare NIC device based on NicTO: {"deviceId":4,"networkRateMbps":-
>> 1,"defaultNic":false,"ip":"0.0.0.0","netmask":"255.255.255.255","gateway":"1
>> 0.0.142.1","mac":"02:00:3b:5a:00:02","dns1":"10.0.31.24","dns2":"10.0.31.28",
>> "broadcastType":"Vlan","type":"Public","broadcastUri":"vlan://142","isolatio
>> nUri":"vlan://142","isSecurityGroupEnabled":false}
>> INFO  [vmware.resource.VmwareResource] (DirectAgent-
>> 47:yul01vi13.ops.dot) Prepare network on vSwitch: P[vSwitch0:untagged]
>> with name prefix: cloud.public INFO  [vmware.mo.HypervisorHostHelper]
>> (DirectAgent-47:yul01vi13.ops.dot) Network cloud.public.142.0.1-vSwitch0 is
>> ready on vSwitch vSwitch0 INFO  [vmware.mo.HypervisorHostHelper]
>> (DirectAgent-47:yul01vi13.ops.dot) Network cloud.public.142.0.1-vSwitch0 is
>> ready on vSwitch vSwitch0 INFO  [vmware.resource.VmwareResource]
>> (DirectAgent-47:yul01vi13.ops.dot) Preparing NIC device on network
>> cloud.public.142.0.1-vSwitch0
>>
> This is a bug, if I'm not mistaken I've seen some reference in source code to try to
use vSwitch0 as default, unless another vSwitch is defined (in your case, its vSwitch2).
> Specifically, the create-schema.sql file and VmwareManagerImpl.java have hardcoded references
of vSwitch0 - that technically should be overridden by "vmware traffic label" defined in "physical
network" settings. Something with a logic there did not go smooth and hence additional creation
of unused port-group on vSwitch0.
>
> Please file the bug and include the content above.
Bug created under:
https://issues.apache.org/jira/browse/CLOUDSTACK-1835

-- 
Francois Gaudreault
Architecte de Solution Cloud | Cloud Solutions Architect
fgaudreault@cloudops.com
514-629-6775
- - -
CloudOps
420 rue Guy
Montréal QC  H3J 1S6
www.cloudops.com
@CloudOps_


Mime
View raw message