cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pranav Saxena <pranav.sax...@citrix.com>
Subject RE: [master branch issue ]Problem with SystemVMs and Primary Storage in latest Master
Date Fri, 29 Mar 2013 06:55:40 GMT
+1 . Always a better thing to have exception handling at the API later but this would be applicable
only if somebody uses the API's to create the zones , assuming we have those UI checks in
place.


-----Original Message-----
From: Nitin Mehta [mailto:Nitin.Mehta@citrix.com] 
Sent: Friday, March 29, 2013 12:23 PM
To: dev@cloudstack.apache.org
Subject: Re: [master branch issue ]Problem with SystemVMs and Primary Storage in latest Master

Besides UI changes suggested below, I also think that we shouldn't allow adding Zone wide
storage in XS/Vmware if the capability doesn't exist.
There should be an explicit error thrown rather than waiting for system vms not starting.

On 29/03/13 12:16 AM, "Edison Su" <Edison.su@citrix.com> wrote:

>
>
>> -----Original Message-----
>> From: Srikanteswararao Talluri
>>[mailto:srikanteswararao.talluri@citrix.com]
>> Sent: Thursday, March 28, 2013 5:02 AM
>> To: dev@cloudstack.apache.org
>> Subject: RE: [master branch issue ]Problem with SystemVMs and Primary  
>>Storage in latest Master
>> 
>> 
>> 
>> > -----Original Message-----
>> > From: Chip Childers [mailto:chip.childers@sungard.com]
>> > Sent: Thursday, March 28, 2013 5:24 PM
>> > To: <dev@cloudstack.apache.org>
>> > Subject: Re: [master branch issue ]Problem with SystemVMs and 
>> > Primary Storage in latest Master
>> >
>> > On Mar 28, 2013, at 6:00 AM, Pranav Saxena 
>> > <pranav.saxena@citrix.com>
>> > wrote:
>> >
>> > > Ok , Suresh was right in pointing that out that we need to select 
>> > > "cluster " right
>> > now as the scope for primary storage with xenserver as the 
>> > hypervisor
>>.
>> >
>> > Sounds like we should actually have the default behavior match the 
>> > previous versions, and make cluster the default.
>> 
>> +1
>
>+1, The UI should use "cluster" wide storage as the default, that's the
>default behavior of createstoragepool API: if no scope is specified, it 
>implies "cluster" scope.


+1 to this.

>
>> 
>> >
>> >
>> > > With "Zone-wide" , we see this error . Perhaps I can introduce a 
>> > > check in the UI
>> > for the scope depending upon the hypervisor type (xen/KVM) since we 
>> > don't support zone-wide primary storage for Xenserver as of now.
>> >
>> > +1
>> >
>> > >
>> > > My set up is working fine now.
>> > >
>> > > Thanks,
>> > > Pranav
>> > >
>> > > -----Original Message-----
>> > > From: Nitin Mehta [mailto:Nitin.Mehta@citrix.com]
>> > > Sent: Thursday, March 28, 2013 3:17 PM
>> > > To: dev@cloudstack.apache.org
>> > > Cc: Abhinandan Prateek
>> > > Subject: Re: [master branch issue ]Problem with SystemVMs and 
>> > > Primary Storage in latest Master
>> > >
>> > > Yes, I saw the same issue yesterday evening.
>> > >
>> > > On 28/03/13 2:29 PM, "Pranav Saxena" <pranav.saxena@citrix.com>
>> wrote:
>> > >
>> > >> Hi ,
>> > >>
>> > >> There seems to be a problem with the latest master branch code 
>> > >> though I did not happen to see any exception being thrown.
>> > >>
>> > >> The system VM's don't come up and the primary storage added as 
>> > >> part of the zone creation wizard does not show up on the host in 
>> > >> the XenCenter UI .
>> > >>
>> > >> Anyone else happened to see this issue ?
>> > >>
>> > >> Thanks,
>> > >> Pranav
>> > >
>> > >


Mime
View raw message