cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Prasanna Santhanam <...@apache.org>
Subject Re: [ACS41] Merge Debian packaging
Date Tue, 19 Mar 2013 12:37:11 GMT
On Mon, Mar 18, 2013 at 05:11:19PM +0530, Prasanna Santhanam wrote:
> On Mon, Mar 18, 2013 at 12:26:30PM +0100, Wido den Hollander wrote:
> > Hi,
> > 
> > On 03/18/2013 07:53 AM, Prasanna Santhanam wrote:
> > >On Tue, Mar 12, 2013 at 05:25:21PM +0530, Wido den Hollander wrote:
> > >>Hi,
> > >>
> > >>In the last meeting my #action was to merge the Debian packaging commits
> > >>from master into 4.1, but I didn't get around doing so.
> > >>
> > >>I found some more time to test it all and it seems the packages are
> > >>working pretty well.
> > >>
> > >>The package I tested mainly was the agent package, but the others should
> > >>work as well.
> > >>
> > >>Now, my problem is the cherry-picking, since I didn't do that so often
> > >>I'm looking for the easiest way to find all my commits (and from others)
> > >>so those can be cherry-picked into 4.1.
> > >>
> > >>What's the easiest way to do this?
> > >>
> > >>Wido
> > >
> > >Hey Wido,
> > >
> > >The commit 8d333ec6648ae6e114309da4b497ef74a1c47912 caused an issue with
> > >cloudstack-agents (CLOUDSTACK-1469) to resurface last week after the merge to
> > >4.1. The dependency JNA was added to help the agent to start successfully in
> > >rpm artifacts.
> > >
> > >Can we just include the jna dependency back in the pom? I've reopened the bug
> > >and assigned it to you.
> > >
> > 
> > No, we shouldn't need JNA via Maven at this point. Libvirt 0.4.9
> > should run with JNA 3.2 which is in both the Ubuntu and RHEL/CentOS.
> > 
> > Running with JNA 3.5 is only required with libvirt 0.5.0 (to be
> > released) and runnign libvirt 0.4.9 with JNA 3.5 causes issues.
> > 
> > The DEB and RPM packages should depend on JNA and you should have a
> > jna.jar in /usr/share/java and the init script adds that to the
> > Classpath.
> > 
> > This works on Ubuntu and should also work in RHEL based platforms.
> > 
> 
> Jna is installed from the centos repos and it is version 3.2.4. I've installed
> the packages onto a centos63 VM and the cloudstack-agent process won't start.
> 
> [root@apache-81-3 ~]# rpm -qa | grep virt
> libvirt-java-0.4.9-1.el6.noarch
> virt-what-1.11-1.1.el6.x86_64
> libvirt-client-0.10.2-18.el6.x86_64
> libvirt-0.10.2-18.el6.x86_64
> 
> [root@apache-81-3 ~]# rpm -qa | grep jna
> jna-3.2.4-2.el6.x86_64
> 
> [root@apache-81-3 ~]# rpm -qa | grep qemu
> qemu-img-0.12.1.2-2.355.0.1.el6.centos.2.x86_64
> qemu-kvm-0.12.1.2-2.355.0.1.el6.centos.2.x86_64
> 

Is anyone else using the agent's RPM artifacts having the problem
described in CLOUDSTACK-1469 or am I missing something in my
environment?

-- 
Prasanna.,

Mime
View raw message