cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Cahill <>
Subject devcloud-kvm questions
Date Fri, 15 Feb 2013 01:40:40 GMT

I've been working on getting devcloud-kvm up and running using master, and
I've hit a few issues - most were due to recent changes in master and are
fixed now thanks to help from Rohit and Marcus. By the way, I should note
that the devcloud-kvm docs on the wiki are really great - couldn't have
gotten this far without them!

*Remaining issue:*
* System VMs don't launch
Using the stock devcloud-kvm image and instructions at [1], system VMs get
launched, but the agent can't reach them over SSH (Control / link-local
network), so they go into a launch-destroy-relaunch cycle.

When I connect to the system VMs in VNC, I see:

SeaBIOS (version seabios-

gPXE ( - 00:03.0 C900 PCI2.10 PnP BBS PMM0620@10 C900
Press Ctrl-B to configure gPXE (PCI 00:03.0)...

I tried making a few tweaks to the libvirt XML for the system VMs and
relaunching them using the tweaked XML, but to little effect - as far as I
can see, it's as though the system VMs aren't recognizing the attached
disks. Anyone have any hints? Could this be related to Rohit's "[BLOCKER]
SystemVMs come up but don't have agent running" thread?

*Fixed issues:*
* No logs from agent
Fix for now with cp /etc/cloudstack/agent/log4j{-cloud,}.xml
* Paused logs on management server when running via jetty
Fix for now with cp
* console-proxy directory moved, caused maven builds to fail
Fixed by Rohit in master
* console-proxy directory moved, devcloud-kvm's custom
/etc/init.d/cloud-agent is now incorrect
Changed this line to reflect the new console-proxy dir:
cp -rp $CODEHOME/services/console-proxy/server/dist/systemvm.*
* Launching the stock devcloud-kvm image using the devcloud-kvm.xml
definition on an iMac running Ubuntu 12.04 gives:
error: Failed to start domain devcloud-kvm
error: internal error guest CPU is not compatible with host CPU

I removed this section:
   <cpu match='exact'>
     <feature policy='require' name='vmx'/>

And the VM launched correctly. Is there any advantage to this exact match,
or should we remove it from devcloud-kvm.xml?

Thanks again to everyone who worked on devcloud-kvm!



  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message