cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vijayendra Bhamidipati <>
Subject RE: Upgrade path for db
Date Sat, 23 Feb 2013 02:35:46 GMT
Hi Min!

Actually I just tried this out and it did invoke the upgrade scripts when I ran the jetty
server to bring up the mgmt. server.. I hadn't copied over the setup/db/db directory either..
did a fresh db deploy and ran the mgmt. server.. thanks for fixing the db checker invocation!


-----Original Message-----
From: Min Chen [] 
Sent: Friday, February 22, 2013 6:07 PM
Subject: Re: Upgrade path for db

Yes, I am running into the same issue. The problem is that DatabaseCreator is not currently
invoking DatabaseUpgradeChecker. I just checked in Commit
5b760f903f1a3145f62d05c1d3c142b710248026 to address this issue, but still have one issue pending
solution, that is, how to tell DatabaseCreator to look into setup/db folder to look for those
sql script in pom.xml. So far we haven't found a solution yet. A temporary workaround is to
copy setup/db/db to your project basedir.


On 2/22/13 3:13 PM, "Vijayendra Bhamidipati"
<> wrote:

>How exactly are db upgrade scripts kicked off during a fresh db install 
>on the master branch?
>When I deploy a fresh db off the ACS master using : mvn -e -P developer 
>-pl developer -Ddeploydb, I don't see the tables specified in 
>setup/db/db/schema-40to410.sql or setup/db/db/schema-410to420.sql 
>getting created.
>The version in the create-schema.sql is 4.0.0 and the same shows up in 
>the newly created db when I do a select * from version;
>How do I ensure that when deploying a fresh db, the tables specified in 
>schema40to410.sql  and schema-410to420.sql get created?

View raw message