cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chip Childers <chip.child...@sungard.com>
Subject Re: Adding a java compat level to our pom.xml
Date Wed, 27 Feb 2013 19:04:01 GMT
On Wed, Feb 27, 2013 at 10:19:49AM -0800, Alex Huang wrote:
> The discussion on java support level caused me to check the poms to see if there's a
compat level set when compiling our source code.  This used to be in ant but looks to be lost
in maven.  I propose that we add the following lines to our maven configuration.  This basically
says that even the source is 1.7 jdk it should work with 1.6 jre.  With this we will have
a level of guarantee that the binaries are compatible with jre 1.6 and on.  This is a direct
result on the discussion on when to eol for java6.
> 
> <source>1.7</source>
> <target>1.6</target>
> 
> --Alex
>

Does this imply that it requires 1.7 to compile, but should be
compatible with 1.6?

Also, we're talking about master (i.e.: not 4.1), right?

Mime
View raw message