cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Min Chen <>
Subject RE: Upgrade path for db
Date Sat, 23 Feb 2013 05:45:30 GMT
My last commit 5b760f903f1a3145f62d05c1d3c142b710248026 is reverted in master. To conclude
this thread, this is not an issue for developer. Just previous db behavior is changed a bit.
Previously, after running deployDB, we will be able to see all db schema created for the branch
we work on. Now with new db sql reorganization, we will only be able to see all db schema
created after running MS first time.

From: Min Chen []
Sent: Friday, February 22, 2013 9:27 PM
Subject: Re: Upgrade path for db

Hi vijay,

     As I mentioned in my previous email, the commit didn't completely fix the problem, which
requires a manual workaround to copy db folder before running deploy db. I checked it in to
unblock you. Since now we realized that starting MS can fix the db  problem, I will revert
my commit.


Sent from my iPhone

On Feb 22, 2013, at 7:07 PM, "Vijayendra Bhamidipati" <>

> I spoke too soon - I hadn't realized I was in another branch when my setup worked, and
the branch didn't have your fix.. now on master, I actually am hitting the exception you mentioned
(of not finding the scripts) with the fix in place and if I revert it, I'm not seeing it anymore..
any chance you may be missing something else in your setup??
> Regards,
> Vijay
> -----Original Message-----
> From: Vijayendra Bhamidipati []
> Sent: Friday, February 22, 2013 6:36 PM
> To:
> Subject: RE: Upgrade path for db
> Hi Min!
> Actually I just tried this out and it did invoke the upgrade scripts when I ran the jetty
server to bring up the mgmt. server.. I hadn't copied over the setup/db/db directory either..
did a fresh db deploy and ran the mgmt. server.. thanks for fixing the db checker invocation!
> Cheers!
> Regards,
> Vijay
> -----Original Message-----
> From: Min Chen []
> Sent: Friday, February 22, 2013 6:07 PM
> To:
> Subject: Re: Upgrade path for db
> Yes, I am running into the same issue. The problem is that DatabaseCreator is not currently
invoking DatabaseUpgradeChecker. I just checked in Commit
> 5b760f903f1a3145f62d05c1d3c142b710248026 to address this issue, but still have one issue
pending solution, that is, how to tell DatabaseCreator to look into setup/db folder to look
for those sql script in pom.xml. So far we haven't found a solution yet. A temporary workaround
is to copy setup/db/db to your project basedir.
> Thanks
> -min
> On 2/22/13 3:13 PM, "Vijayendra Bhamidipati"
> <> wrote:
>> How exactly are db upgrade scripts kicked off during a fresh db install
>> on the master branch?
>> When I deploy a fresh db off the ACS master using : mvn -e -P developer
>> -pl developer -Ddeploydb, I don't see the tables specified in
>> setup/db/db/schema-40to410.sql or setup/db/db/schema-410to420.sql
>> getting created.
>> The version in the create-schema.sql is 4.0.0 and the same shows up in
>> the newly created db when I do a select * from version;
>> How do I ensure that when deploying a fresh db, the tables specified in
>> schema40to410.sql  and schema-410to420.sql get created?
>> Regards,
>> Vijay

View raw message