cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Radhika Nair (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-602) Warn of dependency on mkisofs
Date Fri, 18 Jan 2013 17:22:12 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-602?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13557368#comment-13557368
] 

Radhika Nair commented on CLOUDSTACK-602:
-----------------------------------------

After I installed Cloudstack, there was no indication that the installation failed.  Then
I tried to log into the Management Server UI, it would not let me and gave no indication of
why.   

Yes, the impact is not being able to log into the UI.
Yes, just running ln -s /usr/bin/genisoimage /usr/bin/mkisofs from the management server machine
... and then rerunning the  install management server script ... worked

You see, the install script assumes that mkisofs is on the server machine, but Debian/Ubuntu
install genisoimage instead.   Putting this info in Troubleshooting would help a lot of people.
  Ideally, the install script would simply check to see whether mkisofs or genisoimage is
on the system, and use which ever one is installed. But in the interim, this info in Troubleshooting
should help a lot of people wanting to use Cloudstack on Debian based systems. 

Mel.

                
> Warn of dependency on mkisofs
> -----------------------------
>
>                 Key: CLOUDSTACK-602
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-602
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Doc
>    Affects Versions: 4.1.0
>         Environment: debian 
>            Reporter: Mel Davis
>            Assignee: Radhika Nair
>            Priority: Trivial
>
> cloud-setup-management fails quietly if /usr/bin/mkisofs is no found.  Failure is indicated
only in the /var/log/cloud/management/management-server.log.    This results in the inability
to log into client via the web interface. 
> The docs should at least note the dependency and, maybe, suggest this workaround: 
> ln -s /usr/bin/genisoimage /usr/bin/mkisofs

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message