cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gavin Lee <gavin....@gmail.com>
Subject Re: inconsistent docs in wiki for maven build and devcloud
Date Wed, 30 Jan 2013 15:23:14 GMT
Hi, Sebastien
Following Rohit's blog: http://rohityadav.in/logs/devcloud/
I can build devcloud, but my management server is running in Dom0 not local.
I also used deployDataCenter.py rather than mvn command to deploy a basic zone.

On Wed, Jan 30, 2013 at 8:16 PM, Sebastien Goasguen <runseb@gmail.com> wrote:
> Hi,
>
> I noticed some inconsistent documentation on how to build from source, as well as multiple
devcloud pages that use different profiles and properties.
>
> namely:
> https://cwiki.apache.org/CLOUDSTACK/devcloud-kvm.html
> https://cwiki.apache.org/CLOUDSTACK/devcloud.html
> https://cwiki.apache.org/CLOUDSTACK/cloudstack-devcloud-environment-setup.html
> http://wiki.cloudstack.org/display/COMM/DevCloud
> https://cwiki.apache.org/CLOUDSTACK/diy-devcloud-setup.html (is pre maven)
>
> systemvm was not a profile before, seems to have been made into a profile and now is
a "property"
>
> I do this on my laptop (running mgt server and db there):
> mvn -Pdeveloper clean install -DskipTests -Dsystemvm
> mvn -pl developer,tools/devcloud -Ddeploydb -P developer
> mvn -pl client jetty:run
>
> The configure devcloud with:
> mvn -P developer -pl tools/devcloud -Ddeploysvr
>
> This results in systemvm not starting. No errors in logs.
>
> What's the proper way to build from source for devcloud ?
>
> -Sebastien



-- 
Gavin

Mime
View raw message