cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Tutkowski <>
Subject Re: CloudStack and Networking Question
Date Tue, 22 Jan 2013 20:17:27 GMT
Pranav = Yeah, good idea...I hooked my MacBook up via cable to the network
and disabled the wireless, but it didn't work. :( I did get an IP address
and could access web sites on the Internet, but Tomcat was not running.

Marcus = What is the difference between the Agent and the Management
Server?  I followed the instructions here:

In NAT mode, I usually get as my IP address (no access from my
In bridged mode, as expected, I get an IP address on my company's LAN.

I do have the source code in my Mac OX X environment, so maybe that is the
route I will have to take.

As an oddity on top of this all, if I run Tomcat 6 manually using the
tomcat6 script in /etc/init.d/, Tomcat works.  I can hit
http://localhost:8080, but it doesn't know about

On Tue, Jan 22, 2013 at 11:59 AM, Marcus Sorensen <>wrote:

> Mike, are you just trying to run the management server, not the agent, in a
> VM? If you are trying to run the whole thing, it will fail with virtualbox
> because cloudstack verifies that there is hardware support for
> virtualization before starting the agent. This is not related to your issue
> now, but you may run into it. If you want to run the agent and VMs inside
> this VM, you will need to use VMware fusion and enable the nested
> virtualization.
> Aside from that, check your network in the Ubuntu box and see what you're
> getting in each mode. In NAT mode with virtualbox, you'll have no access to
> the VM from your Mac, because your mac has no IP inside the NAT. This is
> why devcloud uses both NAT and host-only.
> But it sounds like your issue is deeper because you cannot even get
> cloud-management to start. In the past, if I have seen no errors in the
> log, but no success, I have edited the startup script to print out the
> actual command being run to start the management server (with class paths
> and all), and then run it manually, perhaps adding a debug flag. That
> usually gives me the error.
> As an alternative, you can pull the source code, build it, and do the
> 'jetty:run' per devcloud instructions, and that should print debug code to
> your screen. It could at least tell you why the management server won't
> start, even if you don't want to install from master. That will require
> cleaning out the database though, and then setting up the database again
> when going back to 4.0.
> mvn -P developer,systemvm clean install
> mvn -P developer -pl developer,tools/devcloud -Ddeploydb
> mvn -pl :cloud-client-ui jetty:run
> On Tue, Jan 22, 2013 at 11:42 AM, Mike Tutkowski <
>> wrote:
> > Hi,
> >
> > I'm running CloudStack on Ubuntu 12.04.1 in a VirtualBox VM.
> >
> > When I run it in NAT mode, it works (I can bring up the web page to log
> in
> > and my login works).
> >
> > In any other networking mode (bridged, internal, host only), it does not
> > work (Tomcat is not running and I cannot get it to run (even though
> there's
> > no obvious error message) by running the cloud-management script).
> >
> > My host OS is Mac OS X and I am connected to my company's network over
> > Mac's wireless network (AirPort).
> >
> > I have tried to use VMware instead of VirtualBox and come across the same
> > problem.
> >
> > Can anyone think of some reason this might be happening?  Does anyone
> else
> > develop CloudStack on Mac OS X using virtual machines?
> >
> > Thanks!
> >
> > --
> > *Mike Tutkowski*
> > *Senior CloudStack Developer, SolidFire Inc.*
> > e:
> > o: 303.746.7302
> > Advancing the way the world uses the
> > cloud<>
> > *™*
> >

*Mike Tutkowski*
*Senior CloudStack Developer, SolidFire Inc.*
o: 303.746.7302
Advancing the way the world uses the

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message