cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Tutkowski <mike.tutkow...@solidfire.com>
Subject Jetty/Management Server Problem
Date Wed, 30 Jan 2013 16:49:50 GMT
Hi,

I've been having a recurring problem with the Management Server where it
stops responding.

If I Ctrl-C and try to re-run it, it looks like a port is in use still:

mtutkowski-LT:incubator-cloudstack mtutkowski$ mvn -pl :cloud-client-ui
jetty:run
ERROR: transport error 202: bind failed: Address already in use
ERROR: JDWP Transport dt_socket failed to initialize, TRANSPORT_INIT(510)
JDWP exit error AGENT_ERROR_TRANSPORT_INIT(197): No transports initialized
[../../../src/share/back/debugInit.c:690]
FATAL ERROR in native method: JDWP No transports initialized,
jvmtiError=AGENT_ERROR_TRANSPORT_INIT(197)
Abort trap: 6

Does anyone know what process I can kill (or whatever) to avoid having to
re-boot my computer to solve this issue.

The problem is that each time this happens, I've needed to re-boot my
computer and that means brining down 4 VMs I'm also running.

I suppose if I ran the Management Server in a VM of its own, then I'd only
need to re-boot that one VM.

Even better would be if anyone knows why it locks up like this.  :)

Thanks!

-- 
*Mike Tutkowski*
*Senior CloudStack Developer, SolidFire Inc.*
e: mike.tutkowski@solidfire.com
o: 303.746.7302
Advancing the way the world uses the
cloud<http://solidfire.com/solution/overview/?video=play>
*™*

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message