cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wido den Hollander <>
Subject Re: Random compile issue with ComponentLocator
Date Tue, 15 Jan 2013 10:29:56 GMT
On 01/15/2013 10:44 AM, Hugo Trippaers wrote:
> I still have no clue what is causing this. One thing I suspect is that it might be related
to the version of the java compiler used. Not all 1.6 versions are equal and 1.6.0_15 is quite
old, they did make some changes to generics somewhere in the _2x versions.

Well, what makes it even stranger is that I applied Rohit's patch and 
that compiled.

Afterwards I reverted the patch and everything is still compiling.

That strikes me as very odd, how can a piece of code not compile and 5 
minutes later suddenly compile...?

Anyway, it's working again and this discussion is in the archives for if 
somebody stumbles upon the same problem.


> Verstuurd vanaf mijn iPad
> Op 14 jan. 2013 om 19:55 heeft "Rohit Yadav" <> het volgende
>> On 14-Jan-2013, at 7:53 AM, Wido den Hollander <> wrote:
>>> Hi,
>>> I've been seeing the same issue over and over in the last 8 weeks and I
>>> have no idea what it is.
>>> The error:
>>> It sometimes just pops up and goes away again without me touching anything.
>>> I've asked Hugo and David when I saw them at ApacheConEU but they had no
>>> clue as well. It didn't come back since then, but just 5 minutes ago the
>>> issue came back again.
>>> I tried cleaning the whole GIT repo, clear ~/.m2, etc, etc but nothing
>>> works.
>>> My environment:
>>> Apache Maven 3.0.4
>>> Maven home: /usr/share/maven
>>> Java version: 1.6.0_15, vendor: Sun Microsystems Inc.
>>> Java home: /usr/lib/jvm/java-6-sun-
>>> Default locale: en_US, platform encoding: UTF-8
>>> OS name: "linux", version: "3.2.0-35-generic", arch: "amd64", family: "unix"
>>> I have this issue on my desktop, laptop and an external server. All
>>> running Ubuntu 12.04
>>> Suggestions? It's driving me a bit crazy :)
>> So, it's a type casting error and for some reason you java compiler is not automatically
handling it. The fix would be to either fix the typecasting yourself in code or clean install;
assuming you already tried, but just in case:
>> mvn clean install (try doing a clean install)
>> Try to build that on devcloud, maybe some local environment issue?
>> For the code wise typecasting fix, you can try with this;
>> If it still won't work for you, I've no clue.
>> Regards.
>>> Wido

View raw message