cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ilia Shakitko <i.shaki...@leaseweb.com>
Subject Cloudstack usage server doesn't show traffic generated for previous day (CS 4.0.0)
Date Fri, 11 Jan 2013 08:57:41 GMT
Hello everyone.

Last two days we investigate strange behavior of CloudStack usage server.

We have two global settings values:
usage.stats.job.aggregation.range 1440
usage.stats.job.exec.time                 01:15 (CET)

9th of January we've generated some traffic, like 10Gb. But 10th of January we didn't get
anything. I mean, we make apiCall to CSApi: 'command=listUsageRecords&response=json&listall=true&startdate=2013-01-09&enddate=2013-01-11&type=5'
we get zero numbers for our test networks...

We've changed  'usage.stats.job.aggregation.range' to 5 minutes, restarted cloud-management,
cloud-usage services. And made 'generateUsageRecords' apiCall manually. Okay, we've got data
for 9th but it was stored and displayed for 10th.

Okay, we've changed the values back, generated some traffic and get the same today 11th of
January. We can see only traffic for 9th (which we got 10th after manually making apiCall
to generate usage records), but not later generated traffic for 10th...

I have a supposal, that it work at the moment like this (when two values which described before
is set to defaults) :


-------------------------------------9th-----------10th-----------11th----------12th-----------
(traffic     generetad)                10Gb              2,5Gb            5Gb            
  ...
(traffic              listed)                0                     0                     10Gb
           12,5Gb           ...

Is there a bug or where is the root cause?
----------------------------------------------------------------------------------------------------------------------------
Kind regards,
Ilia Shakitko
Innovation Engineer LeaseWeb Cloud

Telephone: +31-(0)6-86423406
Skype: svscorp
Facebook: http://facebook.com/shakitko
LinkedIn: http://linkedin.com/in/shakitko


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message