cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Abhinav Roy (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-628) Upgrade from ASF 4.0 to 4.0.1 fails with some dependency errors on ubuntu 12.04 management server
Date Mon, 17 Dec 2012 14:28:22 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-628?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13533944#comment-13533944
] 

Abhinav Roy commented on CLOUDSTACK-628:
----------------------------------------

David,

Do we need to configure apt repo for 4.0 or 4.0.1 ? I followed the steps to configure ubuntu
apt repo as per the instructions given in the document 

1. echo "deb http://cloudstack.apt-get.eu/ubuntu $(lsb_release -s -c) 4.0.1" > /etc/apt/
sources.list.d/cloudstack.list

2. wget -O - http://cloudstack.apt-get.eu/release.asc|apt-key add -

3. apt-get update.

and I got the following error in the last step W: Failed to fetch http://cloudstack.apt-get.eu/ubuntu/dists/precise/Release
 Unable to find expected entry '4.0.1/binary-amd64/Packages' in Release file (Wrong sources.list
entry or malformed file)

the smae works for 4.0 though.
                
> Upgrade from ASF 4.0 to 4.0.1 fails with some dependency errors on ubuntu 12.04 management
server
> -------------------------------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-628
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-628
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Install and Setup
>    Affects Versions: 4.0.1
>         Environment: MS : ubuntu 12.04 
> Builds :
> ASF 4.0 ------ CloudStack-non-OSS-4.0.0-24
> ASF 4.0.1 ----  CloudStack-non-OSS-4.0.1-8
>            Reporter: Abhinav Roy
>            Assignee: edison su
>            Priority: Blocker
>             Fix For: 4.0.1
>
>
> Description :
> ===========================
> While upgrading from ASF 4.0 to 4.0.1 on Ubuntu 12.04 management server I am getting
this weird dependency error :
> Welcome to the Apache CloudStack (Incubating) Installer.  What would you like to do?
>     A) Install the Agent
>     S) Install the Usage Monitor
>     U) Upgrade the CloudStack packages installed on this computer
>     R) Stop any running CloudStack services and remove the CloudStack packages from this
computer
>     E) Remove the MySQL server (will not remove the MySQL databases)
>     Q) Quit
>     > u
> Updating the CloudStack and its dependencies...
> * Stopping CloudStack-specific Tomcat servlet engine cloud-management               
                                                                                         
                                                                                         
                                                                                         
               [ OK ]
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Note, selecting 'fcitx-module-cloudpinyin' for regex 'cloud-*'
> Note, selecting 'cloud-agent' for regex 'cloud-*'
> Note, selecting 'owncloud' for regex 'cloud-*'
> Note, selecting 'cloud-init' for regex 'cloud-*'
> Note, selecting 'cloudfoundry-client' for regex 'cloud-*'
> Note, selecting 'cloud-agent-scripts' for regex 'cloud-*'
> Note, selecting 'cloud-server' for regex 'cloud-*'
> Note, selecting 'cloud-client-ui' for regex 'cloud-*'
> Note, selecting 'libphp-cloudfusion' for regex 'cloud-*'
> Note, selecting 'cloud-agent-libs' for regex 'cloud-*'
> Note, selecting 'python-cloudfiles' for regex 'cloud-*'
> Note, selecting 'python-rackspace-cloudfiles' for regex 'cloud-*'
> Note, selecting 'cloud-setup' for regex 'cloud-*'
> Note, selecting 'python-rackspace-cloudservers' for regex 'cloud-*'
> Note, selecting 'cloud-system-iso' for regex 'cloud-*'
> Note, selecting 'cloud-initramfs-rescuevol' for regex 'cloud-*'
> Note, selecting 'cloud-initramfs-growroot' for regex 'cloud-*'
> Note, selecting 'ubuntu-cloud-keyring' for regex 'cloud-*'
> Note, selecting 'cloudprint' for regex 'cloud-*'
> Note, selecting 'cloud-usage' for regex 'cloud-*'
> Note, selecting 'cloud-awsapi' for regex 'cloud-*'
> Note, selecting 'cloud-python' for regex 'cloud-*'
> Note, selecting 'cloud-cli' for regex 'cloud-*'
> Note, selecting 'python-libcloud' for regex 'cloud-*'
> Note, selecting 'med-cloud' for regex 'cloud-*'
> Note, selecting 'cloud-deps' for regex 'cloud-*'
> Note, selecting 'libhtml-tagcloud-perl' for regex 'cloud-*'
> Note, selecting 'cloud-client' for regex 'cloud-*'
> Note, selecting 'cloud-utils' for regex 'cloud-*'
> Note, selecting 'cloud-scripts' for regex 'cloud-*'
> Note, selecting 'cloud-core' for regex 'cloud-*'
> Note, selecting 'cloud-agent-deps' for regex 'cloud-*'
> Note, selecting 'python-cloudservers' for regex 'cloud-*'
> Note, selecting 'tagcloud' for regex 'cloud-*'
> python-rackspace-cloudfiles is already the newest version.
> Some packages could not be installed. This may mean that you have requested an impossible
situation or if you are using the unstable distribution that some required packages have not
yet been created or been moved out of Incoming.
> The following information may help to resolve the situation:
> The following packages have unmet dependencies:
> python-rackspace-cloudfiles : Conflicts: python-cloudfiles but 1.7.9.2-1 is to be installed
> E: Unable to correct problems, you have held broken packages.
> * Starting CloudStack-specific Tomcat servlet engine cloud-management
> Note : 
> ========
> 1. This error is not seen during a fresh install of 4.0 or 4.0.1. I am seeing this only
during upgrade.
> 2. The hosts and management server are freshly installed....

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message