cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mills, Joseph" <...@midokura.jp>
Subject Database/code version mismatch
Date Fri, 21 Dec 2012 06:28:15 GMT
There is a database/code version mismatch that currently exists in the
master branch, and I was hoping someone might be able to provide some
insights.

The Database version is set to "4.0.0.2012-09-12T14:47:37Z" (in
create-schema.sql).

However in the top level pom.xml, the code version is set to
"4.1.0-SNAPSHOT".

Is there any reason we are keeping these different?

This causes an upgrade every time we deploy the database, which is not
necessarily a problem. However, in this commit:

https://github.com/apache/incubator-cloudstack/commit/432ea9c7d4aff3f7e682f2951f49ed3e95778d9f


I see the same entry being added to both create-schema.sql and
schema-40to41.sql.

This seems like it would be a problem if schema-40to41.sql were ever
executed by Upgrade40to41.java, but right now it is not added to the
"getPrepareScripts" call. It seems like this should be executed now that
schema-40to41.sql has contents.

Can anyone provide some clarification on this?

Thanks,
Joe

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message