cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kelceydamage@bbits" <kel...@bbits.ca>
Subject Re: Router VM and Network Issue
Date Mon, 03 Dec 2012 20:01:35 GMT
I had a similar issue with KVM and CS on 3.0.2. Turns out the Debian squeeze routers/systemVMs
were incompatible with the vIP HA method I was using upstream(ARP based HA-IPs). It's worth
running tests against any physical or custom virtual routing equipment you might have in the
network path.

Sent from my iPhone

On Dec 3, 2012, at 11:44 AM, "Musayev, Ilya" <imusayev@webmd.net> wrote:

> Marcus,
> 
> I agree with you, except we don't drop any broadcast packets for sure on ESX. That would
be very counter productive.
> 
> Still puzzled - but you could be right - it has something to do with ARP.
> 
> Regards
> ilya
> 
> -----Original Message-----
> From: Marcus Sorensen [mailto:shadowsor@gmail.com] 
> Sent: Monday, December 03, 2012 2:12 PM
> To: cloudstack-dev@incubator.apache.org
> Subject: Re: Router VM and Network Issue
> 
> I don't have a vsphere environment, but it sounds a bit like an ARP issue, where perhaps
the bridge on the VMware host is filtering broadcast or something. Maybe a workaround could
be added to the system VM to make sure things are more robust, but it sounds like something
in your network is disabling the discovery of your router VM via broadcast, and when you ping
from the system vm then the MAC table on the switch is finally updated and things start working.
> On Dec 3, 2012 11:59 AM, "Musayev, Ilya" <imusayev@webmd.net> wrote:
> 
>> So I hit a glitch where a router VM boots up but does not really pass 
>> any traffic unless I ping the gateway of the CS host from within the router VM.
>> 
>> Once the gateway ping goes through, CS is able to SSH into a router VM 
>> and everything is fine and dandy..
>> 
>> But this behavior really puzzles me. Linux network stack is not fully 
>> activated or routing is not fully functional until the initial CS GW ping.
>> 
>> Also I cant ping/ssh the router VM from CS unless a initiate a ping 
>> from within the router VM.
>> 
>> I'm on CS 4.0 and vSphere5. This seem to affect the Advanced Network 
>> setup more than Basic because of routing complexity - as you add some 
>> routes into linux routing table.
>> 
>> 
>> Has anyone seen this before?
>> 
> 

Mime
View raw message