cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Burwell <jburw...@basho.com>
Subject Re: Package Build Procedure
Date Fri, 02 Nov 2012 19:12:20 GMT
Edison,

I have been working to implement this workaround in our integration environment.  However,
when I deploy the WAR and start Tomcat, I am getting the following stack trace indicating
the JDBC can not find the MySQL driver:

INFO  [cloud.upgrade.DatabaseIntegrityChecker] (main:) Grabbing lock to check for database
integrity.
ERROR [db.Transaction.Transaction] (main:) Unexpected exception: 
java.sql.SQLException: No suitable driver found for jdbc:mysql://192.168.123.200:3306/cloud?autoReconnect=true&prepStmtCacheSize=517&cachePrepStmts=true
        at java.sql.DriverManager.getConnection(DriverManager.java:640)
        at java.sql.DriverManager.getConnection(DriverManager.java:200)
        at org.apache.commons.dbcp.DriverManagerConnectionFactory.createConnection(DriverManagerConnectionFactory.java:75)
        at org.apache.commons.dbcp.PoolableConnectionFactory.makeObject(PoolableConnectionFactory.java:582)
        at org.apache.commons.pool.impl.GenericObjectPool.borrowObject(GenericObjectPool.java:1188)
        at org.apache.commons.dbcp.PoolingDataSource.getConnection(PoolingDataSource.java:106)
        at com.cloud.utils.db.Transaction.getStandaloneConnectionWithException(Transaction.java:200)
        at com.cloud.utils.db.Transaction.getStandaloneConnection(Transaction.java:209)
        at com.cloud.utils.db.DbUtil.getConnectionForGlobalLocks(DbUtil.java:58)
        at com.cloud.utils.db.DbUtil.getGlobalLock(DbUtil.java:203)
        at com.cloud.utils.db.GlobalLock.lock(GlobalLock.java:159)
        at com.cloud.upgrade.DatabaseIntegrityChecker.check(DatabaseIntegrityChecker.java:228)
        at com.cloud.utils.component.ComponentLocator.runCheckers(ComponentLocator.java:304)
        at com.cloud.utils.component.ComponentLocator.parse(ComponentLocator.java:276)
        at com.cloud.utils.component.ComponentLocator.getLocatorInternal(ComponentLocator.java:867)
        at com.cloud.utils.component.ComponentLocator.getLocator(ComponentLocator.java:905)
        at com.cloud.utils.component.ComponentLocator.getComponent(ComponentLocator.java:447)
        at com.cloud.utils.component.ComponentLocator.getComponent(ComponentLocator.java:440)
        at com.cloud.servlet.CloudStartupServlet.init(CloudStartupServlet.java:44)
        at javax.servlet.GenericServlet.init(GenericServlet.java:212)
        at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1206)
        at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:1026)
        at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:4421)
        at org.apache.catalina.core.StandardContext.start(StandardContext.java:4734)
        at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:799)
        at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:779)
        at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:601)
        at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:943)
        at org.apache.catalina.startup.HostConfig.deployWARs(HostConfig.java:778)
        at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:504)
        at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1317)
        at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:324)
        at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:142)
        at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1065)
        at org.apache.catalina.core.StandardHost.start(StandardHost.java:840)
        at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1057)
        at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:463)
        at org.apache.catalina.core.StandardService.start(StandardService.java:525)
        at org.apache.catalina.core.StandardServer.start(StandardServer.java:754)
        at org.apache.catalina.startup.Catalina.start(Catalina.java:595)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:616)
        at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289)
        at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:414)
ERROR [utils.db.DbUtil] (main:) Unable to acquire DB connection for global lock system

I have tried moving the mysql JAR from the WEB-INF/lib directory to Tomcat's lib directory
with no success.  I have also tried replacing the mysql-connector-java-5.1.7.jar with the
cloud-mysql-connector-java-5.1.7.jar from devcloud also with no success.  The following is
the deployment environment version information:

Ubuntu 12.04.1
Tomcat 6.0.35 (installed via the Ubuntu tomcat6 package)
OpenJDK 6 (OpenJDK Runtime Environment (IcedTea6 1.11.5) (6b24-1.11.5-0ubuntu1~12.04.1))

Also, for your reference, I have attached the catalina.out and vmops.log logs.

Thank you for your assistance,
-John


On Oct 29, 2012, at 4:46 PM, Edison Su <Edison.su@citrix.com> wrote:

> People are planning to work on the deb build(http://markmail.org/message/lsjigqvnbkjtbl4y),
don't know the status though.
> For current master, the shortest cut is using WAR(~/.m2/repository/org/apache/cloudstack/cloud-client-ui/4.1.0-SNAPSHOT/cloud-client-ui-4.1.0-SNAPSHOT.war)
> 
>> -----Original Message-----
>> From: John Burwell [mailto:jburwell@basho.com]
>> Sent: Monday, October 29, 2012 1:18 PM
>> To: cloudstack-dev@incubator.apache.org
>> Subject: Re: Package Build Procedure
>> 
>> Edison,
>> 
>> Is there an ETA for landing those changes into master?  Also, how do you
>> recommend packaging current master for deployment into an integration
>> test environment?  We working under the (false) assumption that building
>> Debian packages would be the shortest path.
>> 
>> Thanks,
>> -John
>> 
>> On Oct 29, 2012, at 4:11 PM, Edison Su <Edison.su@citrix.com> wrote:
>> 
>>> Packaging doesn't work on master branch, this is a known issue, unless we
>> merged hugo's maven-to-rpm branch into master.
>>> 
>>>> -----Original Message-----
>>>> From: Rohit Yadav [mailto:rohit.yadav@citrix.com]
>>>> Sent: Monday, October 29, 2012 1:01 PM
>>>> To: cloudstack-dev@incubator.apache.org
>>>> Subject: RE: Package Build Procedure
>>>> 
>>>> Edison, building not much problem as packaging, from what I follow
>>>> John is trying to do dpkg-buildpackage which fails.
>>>> Updates, progress on packaging, rpm, debian?
>>>> ________________________________________
>>>> From: Edison Su [Edison.su@citrix.com]
>>>> Sent: Tuesday, October 30, 2012 1:27 AM
>>>> To: cloudstack-dev@incubator.apache.org
>>>> Subject: RE: Package Build Procedure
>>>> 
>>>> Are you using the latest master or can you try it on latest master(HEAD:
>>>> a2d50c7e43f7e7fe1493972646c6f776af9d8143)?
>>>> The build works for me: mvn clean install -P developer
>>>> 
>>>>> -----Original Message-----
>>>>> From: John Burwell [mailto:jburwell@basho.com]
>>>>> Sent: Monday, October 29, 2012 11:37 AM
>>>>> To: cloudstack-dev@incubator.apache.org
>>>>> Subject: Re: Package Build Procedure
>>>>> 
>>>>> Edison and Rohit,
>>>>> 
>>>>> Attached is the output mvm -X -P developer -pl tools/apidoc.
>>>>> 
>>>>> Thank you for your help,
>>>>> -John
>>> 
> 


Mime
View raw message